UE4 refuses to import .uasset and .umap files

After a few hours of developing with UE4, the editor said something about a new version of a map during the boot, and when it loaded, my map was gone, my character blueprint was gone, and several other assets disappeared. I checked in Windows Explorer, which showed they were still there, but weren’t being loaded. I tried manually dragging and dropping, which came up with the error that .uassets/.umap was an unknown file type. Apparently that was because it wasn’t supported yet, but leaving a developer with that sort of error message is quite misleading. After doing some reasearch, I found out I needed to import it using the import button, but the button didn’t allow .uassets or .umaps being imported. Then I found out online that you couldn’t import .uasset files. Have I now lost all my work, or is there a way of recovering it?

Also, there was no engine update when the error came up, I was working offline.

Hi MatthewGB,

You cannot import these types of files. They need to be placed in the content browser. If they aren’t loading then, then they are more than likely from a newer version of the editor than is trying to be loaded with.

And if they are from the same version?..

[= ;243259]
Hi MatthewGB,

You cannot import these types of files. They need to be placed in the content browser. If they aren’t loading then, then they are more than likely from a newer version of the editor than is trying to be loaded with.

what is asset action -> export doing, what is .copy and why i cant drag and drop it into content browser
i think i should be able to do that, whatever this .copy means

Would Love this answered lost countless hours of work from this bug.


The “Action -> Export” is a legacy action (from UE3) which no longer does anything other than create the backend markup text for describing some assets (like blueprints and materials). It should be removed eventually because its not the proper way to ‘copy’ assets anymore.

The “best” way to move an asset from one project to another is to use the “migrate” tool. This will go through all of the asset dependencies and create a list of objects which need to be migrated in order for it to show up in your other project. IE, you have a material which has a texture sampler within the node network, the texture would get migrated as well as the material.

The worse alternative is to just copy the .uasset file from one content directory to another. Any dependencies would have to be copied over manually as well and any internal paths would have to be fixed up as well. There is a lot of room for human error here, so avoid this as much as you can.

If a uasset doesn’t show up in your other projects content browser but you see it within the content file directory, there are a few possibilities:

  1. The file is not compatible with the engine version (moving a uasset from 4.10 to 4.9.2 would not work, but moving from 4.9.2 to 4.10 ‘should’ work).
  2. The file is corrupted and there was some sort of error while the editor was trying to load it.
  3. You modified the engine source code (particularly “ObjectVersion.h” and the internal header data within the uasset is totally different from any of the ‘out of the box’ versions of UE4. This would cause any uassets to be visible within the modified version of the engines content browser, but not vanilla versions.

I’ve been in situations #2 and #3, with months worth of work at the risk of being lost. I managed to fix it, but it took about a full week and digging deep into the binaries of each uasset file and manually modifying certain header signature values via a C# script.

You’ll have to look at the cost vs. benefit ratio of recreating your assets from scratch (or a reference) vs. trying to hack out a solution like I did.

Also: Always make backups!

1 Like

Don’t feel bad. This is the most user un-friendly program I have ever tried out. It’s editor is worthless. Your better off just using VS. I spent half a day attempting to import/merge/copy-paste/and every other tip and can not get one freaking blueprint or map to show up with the same version of editor. Next step is delete and good bye.

::::::::this is driving me crazy.fix your stuff epic goddammit


I am getting the same error I have designed in unreal in the old version and now I am trying to open it in 4.25.1 and it says this
Failed to load map!
…/…/…/…/Users/askh1354/Desktop/Lab1312-master/Content/ExperimentLevel/Exp_Hub.umap appears to be an asset file.


EDIT: FIXED! Checked my /Saved/Backup folder and copied the most recent .uasset and .umap backup to my Content folder, then you have to File > Open Level… because for some reason double click on the file doesn’t work.

I am having this exact problem. I noticed it about two hours ago and I have been trying to pick up the pieces.
My project is likely broken, about 40 hours gone. Really demoralizing.
When I try to load my project, it says “this file can only be opened in a newer version of Unreal” but this does not apply.
Then my project opens with a completely empty black world. The program itself works fine and I can readd assets etc, however the original files are not opening.

I troubleshooted the problem by moving my /Content folder into a new empty project.
I noticed the one clear error is that my primary world .umap and its adjacent .uasset file are not appearing in the content browser. They do not open.
I suspect Slayemin’s comment above is correct the file is corrupted.

The one cause that I can identify as irregular in my process today is that I put my computer to “sleep mode” with the project open, then in a rare instance of clumsiness I disconnected my power strip and shut the computer off with the project loaded to RAM. On was when I noticed my entire project was black. Very disappointing.

I am going to keep my .umap and .uasset file separately and I will check back here for updates. However a bunch of work is gone.

The one redeeming factor is that my other files in the Content folder are salvageable so I don’t have to recreate meshes and materials. However my physical terrain and mesh placement information appears to be lost forever.

absolutely i’ve lost countless versions of files. there is soething wrong with the backup system, and unreal as a whole.