Download

UE4 refuses to find Visual Studio

Current Status: Installed Plugins Prevent UE4 from finding VS - UE4 AnswerHub

https://answers.unrealengine.com/questions/411971/unreal-keeps-losing-visual-studio-cant-package-pro.html

Trying to build my game (hilariously this is because I need to have the game built for another Answerhub response) but can’t due to UE4 not finding VS.

I’ve uninstalled, reinstalled, Repaired, Modified, ect. VS a large amount of times. I’ve gone so far as to install BOTH of them on my C drive after COMPLETELY UNINSTALLING AND REINSTALLING WINDOWS 10. I can’t solve this. I had it working for a single day basically and then it stopped working. I’ve just uninstalled Visual Studio, restarted my PC, reinstalled Visual Studio using the download link that the Editor links to in the “I hate you” tooltip, reinstalled Unreal Engine (Using the launcher and whatnot, and still nothing.

I could live with just using blueprints and being unable to use C++ anywhere. It would suck but it’s not even that bad. But I need it to build my project so… Can I please get some help? I’ve put enough work into this to feel as if I had to completely reinstall Windows 10 so I honestly feel as though I’m at the point where I need help.

I remember reading something about UE4 uses environment variables to find VS and the C++ compiler.
Have you checked to see if any of the VS14 variables are there?

HTH

That said, I did have to manually add the InstallDir key. Probably in the wrong place (the config folder didn’t exist but UE4 didn’t care about it before I reset Windows so… idk)

Edit: To be clear I JUST reset Windows. As in 6 hours ago. I’ve got pretty much nothing installed. The only plugin I have is Substance which, for the sake of testing I suppose I could disable and run a new project but it would be odd if that were the cause tbh.

Have you used the default installer options for VS?, Because C++ is not included by default.

Do you have a previous version of UE4 to test with?

I remember some kinda tool (process explorer or something like that) that could apparently log what an app does.
So that may help if you could get a list of what it tried to do when it came to the VS part.

HTH

The explorer sounds useful though I’ve never heard of it.

Yeah I always install with custom options. Tick everything under C++. At one point I simply installed everything (took hours) just in case I was missing something.
I’ll install 4.10.4 and see how it goes.

Could you post the relevant section of the log where UE4 encounters the issue, Maybe there is some tidbit there that will shed some light on what is happening.

SO weird thing? 4.10.4 packages just fine.

Edit: Well ****. I’ve just figured out that it’s Substance. Disabling the plugin let me package. Time to uh. Time to go to their forum. A new thread. Idk. Super weird.

Edit: It seems that the issue isn’t Substance but rather plugins in general. Quickly installed Rama’s Victory plugin to check this (as I thought it may be the case) and couldn’t package my game for Windows 64 Bit. (Development)

That’s strange, I have the Substance plugin (the version after all the crash issues were fixed) and I can package just fine for Windows x64 (Development).

Is there anything in the log?

No, not at all. All that happens (when I try to package with a plugin enabled) is I get the tooltip telling me that “Visual Studio Isn’t Installed” ; no output whatsoever.

This is limited to a single project. Creating a new project resolves this bug, perhaps only temporarily. This would explain why, as far as I could tell, it happened “out of nowhere”. Willing to PM the project to Epic Staff.

Have you looked at some of the files to see if there is anything that looks like it could be the cause?
Have you tried deleting the “saved” folder from the project, I had to do that when upgrading my project from 4.10 to 4.11 or it would give externally referenced warnings.

HTH

Deleted the saved folder to no effect. Looked through my other folders and deleted things that had to do with plugin data but that didn’t do anything either D:

So what worked was recreating the project and importing the content again?
If so: Very strange.

Have you tried renaming the project folder to see if that helps?

HTH

Changed it. Tried to build and same error as usual.
Tried to cook just in case somehow that would fix it and this time around I got a weird error message.

“Missing UE4 Game Binary” window popped up. Looking into it it has to do with C++ code or the Github version of the Engine. Currently I’m using neither so I’m not sure what that’s about. I’m sure if I disable Substance and/or change my project folder’s name back it would likely be resolved; didn’t see this error a week ago when I packaged the game.

Edit: To be clear I’m not cooking again; it takes forever (40 minutes) and the entire upstairs area went from 85 (already miserable) to a solid 92 degrees.

I have game binaries in these locations:
ToyMission 4.11\Intermediate\Staging\ToyMission.exe
ToyMission 4.11\Saved\StagedBuilds\WindowsNoEditor\ToyMission.exe
ToyMission 4.11\Binaries\Win64\ToyMission.exe
ToyMission 4.11\Saved\StagedBuilds\WindowsNoEditor\ToyMission\Binaries\Win64\ToyMission.exe

The top two are 157KiB and the bottom two are 87MiB

The closest matching exe from the UE install folder is “UE4Game.exe” at 85.6MiB

HTH

-Edit-
Do you have an idea where in the code the editor looks for VS?
If so: You could start the editor inside VS and setup break points in likely locations to find out what and where it is looking for VS.

Hi Travis,

Could you tell me a little more about how you are including Substance in your project? Did you grab the source version from Github or are you using the Marketplace version?

Currently it’s not being used at all. It appears to me that it doesn’t matter what plugin is being used, simply having one enabled is the problem. I wrongly believed it to be Substance simply because at the time it was my only plugin.