Download

UE4 performance question on GTX 570

Hello,

I’m wondering a little thing here. I’ve been checking out all the content examples and I’ve noticed that no matter what I load in the editor, I’m stuck at 20 FPS. This is also happening on Tappy Chicken and I’m not quite sure how something so graphically simple could put my 570 on its knees. Tappy Chicken seems to run fine once built and launched and the CPU is barely being used, so I assume it has something to do with the editor and the GPU.

Is it just my dated graphics card that can’t cope with the editor ?

Thanks

I have the same card and with my test map I’m getting between 30-60FPS, so I dont know if it’s the card.

I updated to the beta drivers right now, and nothing changed. The worse is that the gpu is barely used and neither is the CPU that never go above 10% (i5-760 OC’d to 3.37ghz for reference). I’ve no idea what is going on.

Hi MrMazur,

Please post your question to https://answers.unrealengine.com/index.html, I know it is a hassle but it will help us to assist you further.

Thank you and have a great day!
-Adam

Things that spring to mind.

**
Delete all nvidia drivers/prefs AND<< run nvidia cleaner tool then re-install.
Check you do not have recording software like FRAPS running and its not capping the framerate. This goes for other software too.
Something is wrong with your card and its being capped at a lower speed as a fail safe. Thereby reducing its performance. Check temp.
check in the Nvidia control panel and play around with the Vsync settings.
Possibly a virus leeching your GPU for a bitcoin farm?
Lower lighting quality to unlit see if it changes anything.
Lower Screen Resolution to 1280x1024 (and work your way up if required)**

If none of those work and you find a solution let us know!

P.S.
If someone else with the same card has no problems, then its probably either hardware related, or some profile in nvidia panel. Its a new thing on the block so expect some fixes in the next month or two.

I have an intel hd 4600 and from my brief tests in editor mode I couldn’t go further than 9-10fps no matter what but I thought it was because of my crappy gpu.

I will look deeper into the issue tonight.

the intel APUs are barely graphics worthy, for UE4 you will want a dedicated graphics card not this onboard **** everyone seems to think is amazing for some reason.

I didn’t buy it, it was integrated in the cpu.
Anyway the point was that I may have a similar problem to the op’s, not that my underpowered gpu is not capable of running the UE4( It can)

I’ve found a fix, and it’s pretty hilarious. I went from a constant laggy 17 fps to 120 fps in a simple scene and 40 fps in the reflections subway (all on max).

All I had to do was exit DisplayFusion.