UE4 Perf Woes - iMac

This falls under OS X performance problems.

On my Late 2012 27" iMac (GeForce GTX 680MX), performance really takes a dive when compared to Windows. In UE3.5/UDK, performance was actually pretty decent on OS X however UE4 really takes a step back.

I’m largely posting this here so there’s a better way to keep tabs on the issue than what the forum provides. I’m using OS X 10.9.2.

Yeah. Most designers use Mac, so it should be recommended to finetune the compatibility to the MAC OS graphics engine… its not just about the graphics card. Its the way the Apple hardware and OS works with the system graphics layers like Quartz. This is going to be a challenge, because all the UE graphic display has to be localized. In short: We need a native version sooner or later. Is that being planned?

Try the following patch. We’re aiming to bundle this into a public fix early next week, but want to make sure it fixes your problem first.


Also, try hiding the Unreal Engine Launcher. We’ve had reports that on some Macs it helps with the performance. I’ve been able to reproduce this, actually, so we will be working on a fix soon.

It’s better, but still nowhere near as good as the windows side of things (using the shooter game sample as a point of reference).

Absolutely I can. With this patch, it makes the experience much more tolerable. Thanks!

Yeah, it still needs work, absolutely. And it will get better, promise. For now I wanted to give you this small update, so your experience is at least a little better.

Until we have the same performance as on Windows, maybe you could try different scalability settings in Quick Settings menu (one of main toolbar buttons)? I know it’s not a perfect solution, but may allow you to use the editor more comfortably while you wait for improvements.