UE4 Oculus App Lab submission problem "Your manifest includes the following permissions restricted by Oculus : Read external storage & Access Media Location"

When uploading and when about to submit an UE 4.26 packaged apk to the Oculus App Lab, it gives these warnings and I have been unable to find a solution for this that worked so far. Has anyone else experienced this? Is it possible to edit these from the project settings manifest options?

All help/advice would be greatly appreciated. Thank you in advance!

"Your manifest includes the following permissions restricted by Oculus:

  • android.permission.READ_EXTERNAL_STORAGE

  • android.permission.ACCESS_MEDIA_LOCATION

Please remove these permissions if they are not needed by your application. If they are needed, you must include justification in the “Notes for the Reviewer” field that appears after you click Submit. Failure to provide justification will result in rejection of your application."

Bumping this post…

I am having the same issue about the ACCESS_MEDIA_LOCATION permission even if it doesn’t appear in my application manifest.
I tried the UE4 UPL method to remove useless permissions but it doesn’t change anything since the concerned permission node is not into the manifest.

1 Like

I am also having the same problem.
This is absolutely ridiculous.

If anyone finds an answer I would be very happy to know!


I am currently waiting for my app to be validated and published by Meta/Oculus while still having the issue.
I just mentionned it in the publishing notes, we’ll see what they say. Maybe it’s just a bug.

Hey, any update on that? We’re also entering review stage now with the same problem.

Hi ,

It’s been a while since I submitted to AppLab, but I remember these community videos helped me solve the problem. Vid 1 Vid 2

Also read this thread.

Good luck!

1 Like