Download

UE4 Not changing default pawn class

Hi, I changed my projects default pawn class via the ThirdPersonGameMode class from “ThirdPersonCharacter” to “Ue4ASP_Character”. For some reason, even after multiple restarts and saves/compiles it just doesn’t want to use the new class. I got it from the AnimStarterPack so it should work. If you need any more information please ask. Thanks!

PS. My project IS using the correct gamemode in the project settings (ThirdPersonGameMode).

Delete the gray dude thats already in the scene…its picking him regardless of what your game mode says…

It’s probably because of auto possess.

I’ll go with Cyaoeu on this, but you need to setup your character BP pawn settings and ensure it ties in with the stuff in your project settings (under Maps and modes and general settings >>Default classes)

I was able to fix it by removing the default character placed in the 3rd person example. Im using the Player Start node to determine where the player starts now.