Download

UE4 no audio with attenuation on

Hi to everyone.
I have this problem.
If I put an audio into my editor with attenuation on and with the right click from mouse I choose “play from here”, the game starts and the audio works fine.
But If i start to play the game in stand alone mode or in packaged version the audio don’t works.
To make the audio works I have to deactivate the attenuation with the results the audio volume is the same everywhere.
Where I am wrong? Thanks!

When you play stand alone or package, do you spawn outside of the attenuation radius?

No. I tried several times with different settings but with no results.

Sure you’re not overriding the attenuation somewhere weird, or something? Can you post screens of all the relevant stuff? (Stuff like how audio is placed, any BPs, attenuation settings, instance settings of in-level audio, player position, and other stuff that seems like it could affect it?

Is your sound a 1-shot sound and is thus starting to play outside the max radius of your attenuation? 1-shot sounds will automatically cull if out of range and you’ll never hear it. If you want the 1-shot sound to persist even if out of range (and thus come in range when you walk within the radius), you’ll need to check “bVirtualizeWhenSilent” option for the sound wave. This will tell the audio engine to play it even if its out of range.

Hundreds and hundreds of sounds try to play so we use this max-distance cull as a reasonable optimization for most cases so we can avoid decoding and rendering audio that we won’t hear.

Thanks a lot now It works .

I knew there had to be a magic checkbox somewhere. I started teleporting the pawn to a waiting level while the level streamed in and there was no audio when teleporting back.