UE4 My Projects Loader Glitch

By default, it only scans the User/UnrealProjects folder.
So if anyone saves their projects in another area, it will not add them to the projects list,
and there is no way to manually add them, which makes adding downloaded resources
from the marketplace impossible (unless there’s a manual way to add them?).

That is not correct … my projects sit in a completely different folder and they appear in my launcher. All you have to do is double-click on .uproject file and open the project, this will then add it to your launcher and will be visible from the launcher there on in.

opening a project does not add it to the launcher’s projects list

It does if you project is opening with the correct engine version … well it does for me.

I have both the binary versions and the source compiled versions of the engine … if I open the project and it wasn’t in my launcher before … it appears in there the next time I open the launcher. The trick her is the launcher needs to be closed and re-opened.

As you can see … my projects are nowhere near the default user directory … and they appear in both my areas. H.A.Z. doesn’t appear in the one picture because it is version 4.6 and I don’t have version 4.6 installed anymore.

So I am not experiencing the issues that you are seeing and I am not sure how else to help you. Sorry. 8-{

i’m willing to run teamviewer for you to see, but it does not add them to my launcher, it’s a fresh install of UE4 w/ a fresh install of Windows 7 so no sense is made.
is there a file or registry entry that contains the projects & paths, so I can add them manually?

Even removed old projects and created a new one (and restarted the launcher) just to be 100% positive, and still nothing.

I had the same problem when I recently moved my projects onto a different drive. Opening projects, and changing the version et.c didn’t work. Only thing that worked for me was to create a new empty project in the same location of my other projects, and bingo, they all appeared in the launcher again. Then I just deleted the blank project.

Hope that helps.

Hi K0D3R,

Are you still experiencing this issue or has it been resolved?

Hi TJ, just moved to a new place, got my system up and running again.
I’m attempting a fresh install of UE4 4.7.6 to see if it solves the problem.
I’ll post my progress after it’s all done downloading & installing. :smiley:

Problem solved, tyvm

I have the same problem since 4.8.0. The 4.8 version of the project is in the same location as 4.7 and 4.6, but it dosen’t appear in “My Projects” Nothing works: openning the 4.8 .uproject directly from the browser, closing and reopenning the Launcher, make a new project in the same location, all in vain. I mean, it’s no crucial, but when there is a launcher, I would like to launch my project from it…

Same issue with 4.8. The project shows the second window under project/myproject, but not in the first launcher. Running project and restarting everything doesnt help solve this.

Btw. this is not a fresh install, but updated from previous release. 4.8 preview was not installed prior.

Same issue for me as well. I no longer store the project on my main harddrive. Its in its own area on a secondary. I’m using 4.8 and no matter what I do, the project does show up in the Launcher or when you launch the v4.8 engine. I can open up the uproject fine, but it doesn’t add itself to the launcher or my projects.

I am fully aware that custom engines don’t show up in the launcher, but this one was made fresh with the 4.8 new project creator.

Hi Cosmin, Scumworks, and sbnewsom,

What specific steps are you taking to try to open your project and get it to populate the browser list? Are you using the browse option in the browser or opening the .uproject directly from the folder it is located in?

EDIT: Additionally, you can try the options listed here: No user projects found - Getting Started - Unreal Engine Forums