UE4 Linux: plugin will not recompile

With 4.8, we were able to do the following:

  1. Create a project within Linux using UE4Editor
  2. Close everything
  3. Copy the plugin source to the new project
  4. Reopen which would trigger a recompile.

I try to follow the same procedure with 4.16 (UE4Editor is working just fine and displaying 4.16.3), but I can’t get past

Missing or incompatible modules in
ABCPlugin plugin - would you like to
disable it? …

From the log:

LogPluginManager:Warning: Engine version string in ../../../UE416Vehicle/Plugins/ABCPlugin/ABCPlugin.uplugin could not be parsed ("4.16")

I tried changing from “EngineVersion”: “4.16” to “EngineAssociation” and I no longer get the log warning, but still get the same failure. This plugin in working in Windows with 4.16.3.

The engine version has to consist of three parts, separated by two dots (Major.Minor.Patch)
Changing the version string in your *.uproject file from “4.16” to “4.16.0” should solve the problem.
Although I wonder why this is working for you on Windows as the version string handling should be the same on all platforms (see FEngineVersion::Parse() in EngineVersion.cpp)

1 Like

That change did get me a little farther in the process. Then I needed to regenerate the project files with ./GenerateProjectFiles.sh and then compile with the terminal.