UE4 launcher not opening after linux install

I just now finished installing UE4 on my linux ubuntu 19.04 and the terminal said it was a success, but when I click on the icon for it, it doesn’t open. When I click on the project files it says that the editor failed to open. I even restarted my computer thinking it was just an integration issue that needs a restart. I also tried to doing “sudo apt update && sudo apt upgrade” and it still doesn’t work… Am I doing something wrong?

What branch did you compile? You should go for either Release or 4.22 or tag 4.22.1-release as that is the current version.

Additionally you can launch the editor from command line by executing


In the directory where you compiled the engine and see the error.

Additional information required to help you further. Hardware info and preferably the error message(the full log) why the engine did not start.

I just downloaded the master branch and ran the Setup.sh under that…

Yeah the chances of the master branch actually compiling are not that great… That is where the current development is taking place. Try the Release branch if you can or download one from Releases

You may still need to run ‘GenerateProjectFiles.sh’ and ‘make’. That will generate the binary mentioned above.