Download

UE4 Launcher default save directory

Hello,

UE4 launcher saves content such as sample projects and marketplace items to Windows documents folder. I could not find a screen where I can change this setting. Is there any way to change this directory via UI, some config file or registry?

Thanks,
Yenal

Nope, at least not for now. You can do symlink or if you dont have space on C and throws you disk space error you can move documents in document directory propeties

Hello yenal,

This is currently being worked on, please bear with us until we get a proper fix out. I apologize for the inconvenience.

Thank you and have a great day,
-Adam

I guess I will change the location of the documents folder for now. Thanks for the responses.

Bump. Any updates?

For something so simple, we spend a lot of time trying to hack around it. I find it less and less motivating to continue googling and finding posts from 2014 asking for this. Thanks anyway.

Also bumping this.
I would like to have a way to change the default folder that the launcher shows whenever creating a new project.

&stc=1

I’m not normally one to nag like this… but how is this is still an issue after being reported over and over for 2 years?

Its not like this is much of a feature. There is a settings panel, with a pair of check boxes, and the option to edit the vault cache location, how hard would it be to save a second path for our default projects?

I recently downloaded a bunch of content from the marketplace, and when walking away to let it download after clicking to ‘create project’ for the items that I had not yet downloaded, it proceeded to download and then create, not 1 or 2, but 10, every single new project it had created automatically after downloading, was created in C:\Users\Me… without prompting or warning.

Extremely annoying.

Edit:
I added up what it did to my C drive. It added 10 Gigabytes of content to my C drive, and left it with just 2 GB of free space, on my main boot drive where windows will unavoidably put its updates… bad timing and that drive would have been completely full.

Any updates on this?

I’ve been using the proposed workaround (symlink) for a while now, but I’d love to get rid of having every project shown twice.

=> Does anyone know where in source the damn “users” folder is hardcoded so we could at least compile a version with our own folder.

Thanks!
Dominic

Ok, so “%documents%\Unreal Projects” is still hardcoded somewhere.
Cannot find it in any *.ini file (been searching for “Unreal Projects” through the Launcher’s *.ini-files every few years).

We cannot access source code of Launcher, I forgot about that.
Does anyone have experience in changing values in already compiled .exe or .dll files?
Reverse engineering? Maybe hex editor?
Inside EpicGamesLauncher.exe I could locate “LibraryEngines” & “LibraryMyProjects”, but where is Epics hardcode to “Unreal Projects”?

Y’all use your windows documents folder for unreal or why am I the only one to complain? :slight_smile:

Default Project Directory for the Launcher:

Edit the following file: %localappdata%/EpicGamesLauncher/Saved/Config/Windows/GameUserSettings.ini

Set: CreatedProjectPaths to path of your choice.

Default Project Directory for the Engine:

Edit the following file: %localappdata%/UnrealEngine/{UE_VERSION}/Saved/Config/Windows/EditorSettings.ini
Change {UE_VERSION} to match version you are using (4.23, 4.24, 4.25, etc.)

Set: CreatedProjectPaths to path of your choice.

I am using the very latest Unreal Engine 4.25.1, and I can’t believe over 6+ YEARS LATER and this is STILL AN ISSUE/PROBLEM that hasn’t been FIXED yet! Unbelievable! We spent several hours/days trying to get this “fixed” and couldn’t find ANY WAY to change the paths (in settings or in the launcher) and after several days of struggling with this nonsense, we found THIS POST from 6+ years ago with the “solution”. But then we had to figure out “how to display the %appdata% folder” (which is a hidden folder)

— UNHIDE THE HIDDEN %appdata% FOLDER —

1) To UNHIDE the hidden %appdata% folder just watch the video below:

**— CHANGE DEFAULT PROJECT DIRECTORY FOR THE EPIC GAMES LAUNCHER —

  1. Edit the following file: **“C:\Users<username>\AppData\Local\EpicGamesLauncher\Saved\Config\Windows\GameUserSettings.ini”

3) In the GameUserSettings.ini file, under the “Launcher” heading set: “CreatedProjectPaths=C:/<path name>” (and set this variable to whatever drive/path you wish to use)

  • Set: CreatedProjectPaths= to path of your choice

— CHANGE DEFAULT PROJECT DIRECTORY FOR THE UNREAL ENGINE —

**4) Edit the following file: **“C:\Users&lt;username>\AppData\Local\UnrealEngine&lt;version>\Saved\Config\Windows\EditorSettings.ini”

5) In the EditorSettings.ini file, under the “[/Script/UnrealEd.EditorSettings]” heading set: “CreatedProjectPaths=C:&lt;path name>” (and set this variable to whatever drive/path you wish to use)

  • Set: CreatedProjectPaths= to path of your choice
    (Default is: C:\Users&lt;username>\Documents\Unreal Projects")

You can now change this variable to whatever path you wish to use.

I hope this helps!

Thanks,
Mark

(THANK-YOU to @Slashin8r for the useful post listed above, which was able to help me get started in the right direction and help me find the two** EXACT** files that I was looking for! THANK-YOU!)

2 Likes

Came here specifically for the answer to this question, and here it is on the front page. :slight_smile: Thank you for posting this!

what i do is create a windows shortcut to the location on the drive i want to save (eg. “f:/epic/unreal/projects”),
then i click “browse” and click the shortcut.
this is the fastest solution imo

Bump. This has to become a setting somewhere.

Editing the .ini didn’t help me, maybe it’s having trouble with spaces in my Windows username.

Any updates to this? I want to save my folder to my default custom folders/disks