UE4 keeps running after being closed

I was asked by adam to post for tracking purposes and help (I have kind of fixed it), basically UE4 kept running in the background even when closed, this thread explains everything in more detail A couple of odd problems - Community & Industry Discussion - Unreal Engine Forums.

Hi Smokey13,

Thank you for your report. I have assigned Adam to investigate this issue.

Including the original forum post:

I have started having a couple of very strange issues, first I just tried starting the launcher a few times and it gets stuck on the “checking for update” screen witch I got round by going offline, the second problem is every time I open the editor (version 4.0.2 or 4.1) and then close the editor its still running.

here’s a pic showing what I mean better.

the launcher does it as well but I just checked the task manager again and the launcher has now gone from the list, the really weird thing is that the pic is of the “background tasks” section of the task manager, I checked to see if any other programs/apps have the same thing happen and they don’t.

is anyone else getting the same thing?

–EDIT–

forgot to say the only way I’ve found to get rid of it is to restart my laptop.

Hi smokey,

That certainly does not look like intended behavior! I haven’t been able to reproduce this on my end. Does this occur every time you close the editor or is it linked to a particular project or set of steps taken before closing the editor? Thank you!

yes it did occur every time I closed the editor, it did shutdown after I restarted my laptop the first time but that only worked once, I cant really give you any more information on the problem as I have managed to bodge UE4 so it kind of works but there was someone else that posted in the forum thread having the same problem, maybe he could give more info.

Would you mind providing the dxdiag to your machine? Perhaps we can see what might be causing this to occur. While I’m happy to hear you have a temporary solution to this, we might be able to find something a bit more permanent with more information. Thank you!

its not a temporary solution, its a permanent one that would have probably worked perfectly if the launcher hadn’t updated half way through downloading 4.1 witch resulted in me not being able to launch 4.0.2 from the launcher or launch 4.1 at all, at the moment 4.0.2 is working like UDK (as in I double click on the desktop shortcut and it opens) but I don’t have the problem since the reinstall.