UE4 Keeps crashing when compiling UMG bindings (Sorry if in wrong place)

Hey guys,
Ran into an issue while trying to compile something I made in UMG, Just a simple box thing (doing a tutorial for UMG)

Its been happening everytime ive tried to do it so I’m stuck on this part of the tutorial. Basically I create a boolean whilst trying to make a binding, hook it up, and it either crashes there or when i need to compile.

I added the logs that came up just cos I know people tend to want to see them.

Any help would be appreciated. Cheers

Access violation - code c0000005 (first/second chance not available)

UE4Editor_UMGEditor + 1295505 bytes
UE4Editor_UMGEditor + 1469887 bytes
UE4Editor_UMGEditor + 1063486 bytes
UE4Editor_UMGEditor + 780609 bytes
UE4Editor_UMGEditor + 1542044 bytes
UE4Editor_UMGEditor + 1380179 bytes
UE4Editor_Kismet + 992204 bytes
UE4Editor_Kismet + 1007276 bytes
UE4Editor_Engine + 600292 bytes
UE4Editor_UnrealEd + 9881830 bytes
UE4Editor_Kismet + 727159 bytes
UE4Editor_Kismet + 992849 bytes
UE4Editor_Kismet + 1007926 bytes
UE4Editor_Slate + 588774 bytes
UE4Editor_Slate + 1535133 bytes
UE4Editor_Slate + 1030727 bytes
UE4Editor_Slate + 1037049 bytes
UE4Editor_Slate + 1435577 bytes
UE4Editor_Slate + 2116506 bytes
UE4Editor_Slate + 2296435 bytes
UE4Editor_Slate + 432060 bytes
UE4Editor_Slate + 160583 bytes
UE4Editor_Slate + 832224 bytes
UE4Editor_Slate + 770598 bytes
UE4Editor_Core + 2484713 bytes
UE4Editor_Core + 2400763 bytes
UE4Editor_Core + 2489275 bytes
UE4Editor_Core + 2387186 bytes
user32 + 105425 bytes
user32 + 104666 bytes
UE4Editor_Core + 2490486 bytes
UE4Editor!FEngineLoop::Tick() + 3434 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\launchengineloop.cpp:2193]
UE4Editor!GuardedMain() + 479 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\launch.cpp:131]
UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]
UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\windows\launchwindows.cpp:202]
UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

Sadly I need a stack trace with debugging symbols to make heads or tails of that data. Do you have a sample project that reproduces the issue you could send me? Also, have you tried doing it in the 4.7 Preview 5 version?

I’ll be honest with you, im new to this, so i have no idea what you mean ahaha.

Basically I can show you the part of the tutorial I’m working on if that will help.
And no I haven’t, I’m in 4.6.1 at the moment.

Step 9 is where it keeps crashing, every single time.

Ive moved onto other tutorials in my spare time until I figure out whats wrong with it.

UPDATE: Spoke to one of my team members, we found 2 things not connected together in one of the blueprints, after we fixed this there was no crashing anymore. thank you regardless for your help ^^

What two things? Things shouldn’t crash in blueprints, connected or not. We need to fix whatever it was that you were calling that wasn’t handling the case you were giving it.


Hi guys

I had to change for 4.7 because I was exploding 4.6.1 working with UMG and gave BP when compiling :frowning: