UE4 is unable to build the project files on VS2019 due to Hololens

VS2019 Latest update is installed. SDK 18362 is installed (in addition to 17763 that required by cmake).

And I can’t generate the project files for ue4 itself or for any project made with it. (can use -2019 -Platforms=Win64 but that doesn’t solve the project issue)

Setting up Unreal Engine 4 project files…

Binding IntelliSense data… 100%

Writing project files…

Using x64 architecture for deploying to HoloLens emulator

Building using Windows SDK version 10.0.17763.0 for HoloLens

Writing project files… 94%

ERROR: Unable to find Visual Studio 2017 toolchain; ‘Latest’ is an invalid version

GenerateProjectFiles ERROR: UnrealBuildTool was unable to generate project files.

I have the same problem on 4.23 branch.

Yeah, 4.22 is the latest one that has no this issue. I’ve just switched to it until this will be fixed (I have no clue how to fix it myself).

When both VS2017 and VS2019 are installed the problem is gone.

Do you need a HoloLens staff?

*stuff? No. I don’t.

Well, obviously. Cause it uses VS2017 toolchain to build it. But that’s not solving the issue of building it with VS2019.

Hi S-ed,there was always and issues with downloading the SDK’s libraries from this *.bat scripts when you have installed 2 Visual Studios on your PC,I don’t know if Epics fix it.In this *.bat file it’s going and searching for the VC toolchain on your PC and if you have both this script a little bit fails.Also an issue can be that Epics doesn’t build this library with 2019 compiler and this library doesn’t present on Epics server and when the *.bat file tries to found the libs there is no pathes.Basically if don’t need this Module,you can Switch it off and there will be no problem.

I have only 2019 installed. GitDependencies fetching files from Epic repo by the list(.ue4dependencies) they generated from the files they have on that repo. And Setup.bat is not the same thing as GenerateProjectFiles.bat. It’s not the issue here.
Hololens is not a module it’s a part of Runtime Core (At least a can’t find any .build.cs for it).

Hi again,well this module present as “windowsmixedreality”.Its located here,i’ve attach the image.Probably would be best to remove it and all plugins and all dependencies if you needed.

Nah, it’s just a plugin. I’ve tried to delete one. Still got the same issue.




Are still part of the build.

But according the error message you took the branch for early access to HL2 code. Yes, the branch has a partial support for VS2019 but single installation have been never tested. I would look on the issue, but I strongly advise to take an official release with proven VS2017 support.

No, it’s inside UnrealBuildTool

Not actually. In the case you use VS2017 for building UnrealBuildTool and AutomationTool at solution generation step. Then you use VS2019 for building the editor and a game.

Well, it’s a Master branch and we’re in Bug Reports section. I’m hoping for some kind of a solution (means, making UE4 to work on vs2019).
For me personally it’s ok to disable the HL, but no one yet told how to do that (except Maksym, but that’s just for plugin and did not help).

“No”? It’s not the plugin Maksym linked? Pretty sure it is. And I’ve said it’s not the plugin that causes the issue.

And how the part “it’s inside UnrealBuildTool” should help to solve the issue? Please be more specific.

You can’t completely disable HL code because you in active development branch. Releases are here:


Solution for running UE4 on vs2019 in the branch is already suggested by michal-z

Yes, the code caused the issue isn’t in the WMR plugin. It’s inside UnrealBuildTool. You can ignore it by installing VS2017.