UE4 installs on wrong hard drive

My Drive C: is full… up until now i have been installing stuff on drive D because thats where the launcher is installed, but for whatever reason… maybe after last time i updated launcher it tries to install everything on drive C:… im just trying to install the last version of 4.10.2 and i am unable to because it thinks i dont have enough hard drive space. I cant install on drive C since the drive C on that computer is very small. I need the engine to install on drive D:… what do i do? Seems like a bug. I have tried to uninstall and reinstall epic games launcher with no good result. Problem persists so that computer currently cant install the editor :confused:


Open your launcher and try to change the cache folder, see picture:

The cache fodler is already pointed to a drive D:) location… which is where i want it to install… which it is not installing too…

I have tried to not allow it to calculate necessary disc scpace nad click install right away… in which it proceeds to download and attempt to install, but then it tells me i couldnt install the necessary prerequisuites… HELP!!!

I’ve tried uninstalleing epic games launcher, deleting everything that says epic on appdata folders, and deleting anything that says unreal in app data folders… Finally i reinstalled epic games launcher to drive D:… and still… the problem remains. I cannot uninstall unreal editor. This is beginning to get in the way of work a lot… please help…

Hello kurylo3d,

I apologize for the delayed response. Do you have any other engine versions installed? Can you verify in Windows Explorer that they are present in the correct directory? Can you send me a screenshot of the Unreal Engine tab showing your installed version?

Also, please follow the steps here to generate your debug logs? Please start the engine installation then cancel it so that the action is captured in the logs.

No other engine versions are installed, though in the past i have had 3 different engine versions installed… which is odd… i think the last engine version i had installed was 4.10… not 4.10.2 or 11.

I have verified in windows explorer that everything does in fact go to drive D:, again i cant install the engine sadly. It allows me to download it if i dont allow it to check for required disk space(that takes a couple of minutes for whatever reason)… but if it ever does check the diskspace… i cant even start the download. In fact even if i relaunch the epic games launcher since it already checked the disk space i cant start the download unless i uninstall and reinstall it again. Again no screenshot for unreal engine version since i have no unreal engine versions installed… only the epic games launcher. I ahve been attempting to install 4.10.2. I will reply later when I have time to attempt to generate logs for you.

Did you guys make some sort of update to the launcher? I tried it again today because I was going to do the debug thing for you. It automatically updated the launcher when i started it. Then i went for the install of 4.10.3 and it looks like it succeeded now.

I’m having the same problem. I deleted all the files on the D: drive, unistalled it from my computer. Then re-enstalled it with the file directory to the C: Drive in the setup. It continues to go to my D: drive. Unfortunately, they updated their launcher but it still doesn’t work.