Download

UE4 - How to optimize ambient sound?

Hi, I created a blueprint with a sound component, to play a certain type of ambient sound in 10 different locations, then I click play and my FPS drops from 90 to 55… OMG

then, instead of using a BP I addet “ambiensound” objets to the viewport, (BTW all my cues have attenuation limits, you wont heard the sound unless you are close) than I click play… same problem, FPS drops… I delete them all, and FPS returns to 90 to 120

How to optimize sound?

How many ambient sound objects?

Just about 10 ambient sounds (all limited to an area), plus a background sound.

Kind of a solution: For now I created Blueprints to handle the cues, so when the actor is way to far, each sound is de-activated, that restored my FPS.

A new problem:

UE4 sound is soooo low… and I received a bad feedback for that in an store long ago, in order to improve this I went to the “master” (project settings) and raised volume from 1 to 7, now it sounds better, but I can not raise it more than that, changing the value to 15 for example, does nothing… BUT, now… sometimes (not always) some sounds when I reach to their location, they kind of saturate the buffer and sound bad, they produce a heavy noise to the track like if the speaker is about to break LOL, I thought I could fix this by setting them to a higher “priority” inside each track… not working, noise keeps appearing, is there something I can do to fix it?

To test if it wasn’t my PC, I played a game with high volume… no problem, only with UE4… and even at 7, volume sounds lower that the game I tested.

Do you know another way to raise UE volume?
How to avoid strong sounds from saturating UE4?

To avoid strong sounds from saturating the output (and clipping) and yet having softer sounds be head, you need to apply proper gain structure. Balancing all the different audio levels is an art, just like, say, using color schemes that go well, or designing animations that look natural.

The FPS should not change that much from audio cues. You must be doing something else, like adding a separate convolution reverb per sound object, or re-starting the sound objects every frame, or doing some call inside Tick, or something?

I just added the cues to the viewport with the default settings, the only setting that I changed, was the Attenuation, so the audio goes down, when reaching the max distance, nothing else.

I have certainly laid out various ambient sounds with attenuation, it’s not a problem.

As for the sound being too low, take a look at the waveforms in the content browser. This sound

image

is well formed, this sound

image

is too quiet.

Don’t adjust the main project volume, because, as you’ve probably realized, this will screw everything else…

1 Like