Download

UE4 has been acting up today

Hello,
So i’m having trouble with UE4.
I fired up the launcher this morning only to see that my projects weren’t listed and I apparently had no engine installation. Not sure if this is normal behavior when there’s a new update.
So I tried to download the new version and it went pretty smoothly until it got stuck at installing for about an hour. I relaunched the launcher and it got stuck at verifying for some time but it did finish eventually.

So I went to my project folder and launched the project, midway through windows just displayed a grey screen while my pc fans immediately went full speed! (not sure which fans exactly)
I restarted my pc and reopened my level and it was working fine so I started working on it. Specifically was trying to get the Dynamic Global Illumination working. (Just found out about it, cool stuff)

While using Chrome with Unreal in the background I opened a youtube video when suddenly I got a cyan screen while my fans started screaming again.
(Not sure if the video had anything to do with it)
I restarted again and haven’t opened it since.

Can someone tell me what’s going on? If I need to upload any log files just tell me.

AnswerHub: UE4 freezing my PC - UE4 AnswerHub

Try putting this on the answerhub as there are more epic staff checking that out, add a link in here too so other people can find it. Hope it gets sorted

I tried to open it again and my pc crashed within 30 seconds after the map loaded.
What the actual hell is going?