Download

UE4 Flex Build Troubles

I am building the UE4 flex branch.
Setup.bat ran just fine.

When running Generate .bat I get an error cannot find path to Visual Studio 2012 and check Hkey. I am using 2013 as 2012 is no longer available for download. The requirements seemed to state that 2013 would be ok.

Do I edit the .bat to put in the path to 2013?

What would I do for the Hkey?

Screenshot:

65b3acfec4685bd722f8cf28fc3957233a2b239e.png

Try doing a repair on your visual studio 2013 installation, sounds like it isnt installed correctly.

Discovered I had 2015 installed alongside 2013. Uninstalled 2015 (and the 2015 C++ distributables). Repaired 2013,
still no dice.

So checking the HKEY, I don’t have InstallDir under that path. I have InstalledProducts.
Running VS Community 2013, Update 5.

Screenshot:

4019b2c2718e6a3a5f2625e146563520b5cf86b9.png

There is also the cmd.exe is not a recognized command at the top of the error.

The second line of GenerateProjectFiles.bat.

cmd.exe /v /c “%~dp0Engine\Build\BatchFiles\CopyVisualizers.bat”

So if cmd.exe is not recognized?

Bumpity Bump bump.

If you open a command window, and type “cmd.exe,” does it properly run that command?
If not, then your PATH variable has been corrupted. You can type “path” in a command line window to see what it’s set at.
You can then edit it in the Environment Variables system setting. Remember that the PATH is the composite of the for-everyone, and per-user, PATH values, so you have to check both places.

Got it. Was not checking the user PATH, just the system PATH.

Works now!