Download

Ue4 enemy collision impact bounce impulse issue (physics?)

Hello everyone, I’m having an issue with my enemy colision where everytime I hit them they fly every where due to the sword on the capsule collision. At times it will react to the sword collision and flinch and sometimes it’ll ignore it, as at others it’ll just buonce either upwards or or any direction for a ridiculous distance. Ideal would be for them to flinch and have a little launch every time theyr’e hit. And always react. The enemy collision capsule is on pawn and the characters is on custom pawn, with the pawn reaction to overlap. Because when pawn reaction was on block all, the enemy would bounce the character the same way the character bounces them. its kinda like a repel or the colision impulse or something like that. I’ve tried playing with all the custom settings but have found no solution.
Heres the video: https://youtu.be/EwQVXFSA0WQ
Let me know, Thanks.

Nice graphics.

I wish I had a sword in my game that makes them all fly off the bridge like that. You’re good at making games with this Engine… I’m not as good
with this Engine in making my game unfortunately because I don’t have all those skills you guys have, however I do know something about this issue and it looks like the collision of the pawns are working just fine.

Enemies are Falling through the floor… Not sure what’s causing that, but check to see if your floor mesh has a collision on it to detect also those enemy pawns because it should be blocking off the enemies so that they can’t fall through the floor.

Enemies flying too far away. Click on the enemy and Under Mesh there’s a setting under it called Massinkg for setting the different weights
of the mesh…Increase the weight of the mesh and that should stop the engine from throwing it away so far. If that resolves it, then the enemies should only be thrown a small distance away.

@paulusartiss In my experience complex collisions are not that accurate when the game is played in the editor. This may be due to the overhead of the editor and the engine skipping frames/collision detection to keep up. Do you have the same behavior if you play it as Standalone Game or as packaged game? Did you try to turn CCD on?

Cheers,
Marco.

I have to agree with Vr Marco I sense that the collision is not as accurate in the editor as well. CCD ? Complex Collision Detection?

Thanks for the complimentent. but I’ve accomplished it all with tutorials, theres tons of them. (and with you guys’s help of coarse.)

Yeah CCD is on. Thing about the MassInKG tab is, for it to function you have activate simulate physics, and as soon as I activate simulate physics the enemies stop moving. They don’t come seek play or react to my attacks when hit. As in they don’t move from they’re place, but they do play the flinch animation.

Yeah, you do have to activate the physics to use MassinKG… Hmm that’s strange, the enemies shouldn’t be disabling themselves soon as you turn physics
on in the world. Is overlap events active ? The physics shouldn’t be cancelling the pawns out, I wonder what’s going on with these blueprints.

Heres the vid, check it: https://youtu.be/VO5lLWHgJcY

@paulusartiss Do your enemies have a CharacterMovementComponent in them? I can’t really see it from the video. If yes, what is the status of Physics in it? Can you try to turn off physics on all components of your enemy and tick Enable Physics Interaction? Do they still fly away?

That did it! I deactivated the physics on the movement component on both enemies and main char and it worked. Thanks man, great help.

How big is the level? For there’s significant slowdown and jerky framerates going on in the editor when trying to play the game. What’ is the framerate and speed like when playing the build?

Nah, Thats just the recording program, The game plays perfect. Its only on the recording that it lags. i wasnt able to completely fix the collision, They don’t fly away, but they go through you, which is not desired.
You can download the prototype here: Patreon

Let me know what you think, And if you have any advice on how to fix it lemme know.

Are you putting a mini map in the game or is it a small level? Have you tried putting a collision sphere around the pawn so when they do hit the player they won’t go straight through the player? Because enemies shouldn’t be going through the player. I remember when i tried to set up an AI Group of party members to follow me around in the game, that unless I put in a collision sphere around each pawn that was following me, they would all bunch up inside of each other…

Well, I clicked on your download link, but all that came up was just a bunch of these tags and clicked on that
and it kept popping up more tags.

If I put a collision sphere it’ll stop them from going through, but itll bring back the bugg where they randomly fly really far away every time you hit them. so thats why It put the collision on query only.

It’s just a small level for now, thats just the prototype. It’ll have a lot more levels later on. And it’ll be online.

Try here: MEGA

I hate blueprints. It makes me wonder if the system has been even tested properly before releasing engine versions… is there no testing department to catch these bugs in?