Download

UE4 Electrical power usage a problem.

Hi,

I bought a watt meter to test how much power my computer is using, when UE4 is in idle, it still uses approximately 170watts on my computer.

Now that is of course, relative to my computer and GPU, I am running a GTX 570, a fairly power hungry card, it is costing me approximately an additional 7c an hour to run unreal engine on my computer. This might seem like it doesn’t mean much, but for me it means I need to be consious, not to have UE4 running in the background when I am not using, I would probably use my computer for 70hours a week, that’s about $5 a week if I keep UE4 running the whole time and an extra $20 a month to my power-bill, thus UE4 is as expensive to run, as it is to subscribe to.

My electricity is not super expensive here, it is like 0.25c a kilowatt hour. My math is a little bit wonky here, but this is something epic can test itself, there is no need to take my word for it and an issue I’d like to bring to the community and if there is a simple fix, I’d like someone to implement that.

Here is a video I made about this: - YouTube .

What happens if you use the console in the top right to type the following?


t.MaxFPS 30

Why on earth would you be running your rig 24/7 if you’re worried about electricity to begin with?!

You could also try to set the energy setting of your pc to “power saving” + turn down the quality of the ue4 + close all other programs on your pc + also close the ue launcher after you have opened the engine (the launcher consumes a lot of your ram) + turn down the screen brightness :slight_smile: -> I do everything that I mentioned when I’m using the UE4 on my notebook

WOW THANKS Veovis Maud’dib!!!

My watt usage immediately dropped by 100watts, from 380 to 280! Incredible!

This is surely a must-know for anybody running UE4 on a laptop.

Also,

There is this on the roadmap: Trello

Stefan, I am not running my rig 24/7, I turn it off when I go to sleep or go out and what I have said takes that into account.

My screens each take about 30watts of power.

The main reason for this is because GPU’s usually spin up to full speed when the editor is open. You could buy a GTX 980 for it’s insanely low power-consumption :stuck_out_tongue:

My 980 sits at 48% usage with a scene open in UE4, but it does actually drop to 0% when UE4 is minimized. Previously, my 560 Ti would sit at 99% usage continuously, and would be practically on fire and draw considerably more current through the mains.

Hey TheJamsh, I’m really excited about the new generation of Maxwell technology and its power-saving features, I cant afford a 980 right now tho :\

It is very important to note that you must do this on every launch.

Previously there was a method to apply this change permanently, but it no longer has any effect as of 4.4 at least.

Couple of other quick notes here:

Turn off “Realtime” when you are not using the viewport, if you have a blueprint open in front of the viewport, it will still be processing the scene in the background. Also make sure you do this before walking away from your PC, it will save a lot of power. Just press CTRL+R to toggle it on/off.

Go into your Editor Preferences and check the box to “Use less CPU while in the background”, this will lower the usage whenever UE4 is not the active window. When used in conjunction with realtime turned off, UE4 will not use up resources while it is not active. See attached to find this setting. :slight_smile:

It works on 4.4.0. Just put t.MaxFPS=30 in ConsoleVariables.ini.

facepalm I played games around the Quake era, I should have looked for something like that first…

Thanks for the heads up!