Download

UE4 editor simply crashing when importing FBX... :-( ?

UE4 editor simply crashing when importing FBX… :frowning: ?

I created a simple 572 polygon night lamp, exported from 3dsmax 2014 in FBX 2013 Binary format, embedded media. Then when I import the model into UE4, it just crashed and shows a “Sorry for the inconvenience” message…

Am I missing something here?

What are your import settings and what media are you embedding in the fbx file? Try not embedding media as a start to see if that is the issue. If you haven’t already done so please submit the crash report so we can identify what is going on with the fbx file.

It imported OK without materials or textures! Now I’m looking into why the JPGs I’m using won’t import. I’ll try TGAs and PNGs.

I’m getting a lot of crashing with files that worked fine with UDK—tested both the original FBX files and exporting again from 3ds Max. Also tested embedding the texture or not still causes a crash. The only fix I’ve found is to apply a new material in 3ds Max (using all the same settings) or to resave the texture map, same settings there too–24-bit or 32-bit targa.

iget same issue here , import in UDK forks fine include texture , in UE4 it`s insta crash .

If you guys don’t mind sharing any assets that reproduce this for us we can take a look at it ASAP.

I had a similar problem.

The map I’m converting from UDK is done in one big mesh as the reference proxy as to where everything has to go and in UDK no problem. In UE importing the same FBX the progress bar just sits there.

Don’t know why but by unchecking Combine Mesh and One Convex Hull Per UCX (which I have many) solved the problem.

I’ve got the same issue. When I import without the materials, it works fine. When I try to import the materials along with the object it crashes. Here is my ugly little ship that is causing the problem.

https://www.dropbox.com/s/293oydxgm45a5vw/ship.fbx