UE4 Editor preventing PC sleeping

+1. This happens to me also on the latest 4.17.0. In addition to the audio request you have mentioned, I also have this: [DRIVER] Legacy Kernel Caller

Hi all,

I’ve noticed that if i leave UE4 Editor open my PC will never sleep. This is bad for the environment and bad for my electricity bill, and lowers the life expectancy of my PC parts.

I’ve done some investigating and found that this happens with all UE4 editor versions between at least 4.8 and 4.17, it seems that while the editor is open it opens an audio stream for the editor sounds (even if editor sounds are disabled!) and doesn’t close it until the editor closes. There seems to be no way to disable this functionality.

This causes the sound driver to request a sleep override within windows’s power management system:

C:\WINDOWS\system32>powercfg /requests
DISPLAY:
None.

SYSTEM:
[DRIVER] VIA HD Audio (HDAUDIO\FUNC_01&VEN_1106&DEV_0441&SUBSYS_1458A014&REV_1001\4&305c0d3e&0&0001)
An audio stream is currently in use.

AWAYMODE:
None.

EXECUTION:
None.

PERFBOOST:
None.

ACTIVELOCKSCREEN:
None.

I’ve managed to work around this for now by adding a request override for the sound driver, but this means of course that the PC might go to sleep if i’m watching movies etc.

Is there a better fix without modding UE4?

Thanks!

Would love a solution to this also, Epic staff?