UE4 Editor Crash When Opening Game

I was working on my game, playing it in editor to test, and it crashed editor. When I went to reopen game I got a message stating " module ‘Game Name’ could not be loaded. There may be an operating system error or module may not be properly set up." I tried opening game from games launcher and by double clicking on GameName.uproject file, right clicking on uproject file and selecting generate visual studio project files, in visual studio building project, and I tried to revert my changes in git, restarted my laptop and I keep getting this error. Any answers or suggestions of things to try is greatly appreciated. I get following stack trace:

Updated from crash reporter to include machine id.


Access violation - code c0000005 (first/second chance not available)


UE4Editor_CoreUObject!UObjectForceRegistration() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\coreuobject\private\uobject\uobjectbase.cpp:348]
UE4Editor_CoreUObject!UObjectProcessRegistrants() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\coreuobject\private\uobject\uobjectbase.cpp:333]
UE4Editor_CoreUObject!ProcessNewlyLoadedUObjects() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\coreuobject\private\uobject\uobjectbase.cpp:750]
UE4Editor_CoreUObject!TBaseStaticDelegateInstance::ExecuteIfSafe() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\public\delegates\delegateinstancesimpl_variadics.inl:921]
UE4Editor_Core!TBaseMulticastDelegate::Broadcast() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\public\delegates\delegatesignatureimpl_variadics.inl:809]
UE4Editor_Core!FModuleManager::LoadModuleWithFailureReason() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\private\modules\modulemanager.cpp:394]
UE4Editor_Core!FModuleManager::LoadModule() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\private\modules\modulemanager.cpp:298]
UE4Editor_Engine!FModuleManager::LoadModuleChecked() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\public\modules\modulemanager.h:276]
UE4Editor_Engine!UNavigationSystem::CleanUp() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\engine\private\ai\navigation\navigationsystem.cpp:3527]
UE4Editor_Engine!UNavigationSystem::~UNavigationSystem() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\engine\private\ai\navigation\navigationsystem.cpp:320]
UE4Editor_Engine!UNavigationSystem::`vector deleting destructor’()
UE4Editor_CoreUObject!IncrementalPurgeGarbage() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\coreuobject\private\uobject\garbagecollection.cpp:1152]
UE4Editor_CoreUObject!StaticExit() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\coreuobject\private\uobject\obj.cpp:3718]
UE4Editor_CoreUObject!TBaseStaticDelegateInstance::ExecuteIfSafe() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\public\delegates\delegateinstancesimpl_variadics.inl:921]
UE4Editor!TBaseMulticastDelegate::Broadcast() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\core\public\delegates\delegatesignatureimpl_variadics.inl:809]
UE4Editor!FEngineLoop::AppPreExit() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\launchengineloop.cpp:2941]
UE4Editor!FEngineLoop::Exit() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\launchengineloop.cpp:2202]
UE4Editor!GuardedMain() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\launch.cpp:153]
UE4Editor!GuardedMainWrapper() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]
UE4Editor!WinMain() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\windows\launchwindows.cpp:200]
UE4Editor!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:264]

Hi jman,

Does Crash Reporter window show up? If so, can you copy text from that, including Machine ID, and paste it here for us after clicking Send? Thanks!

What is above is from Crash Reporter. I deleted project directory and cloned it from git repo and that worked for a bit but now I am having same problem again. I again tried to delete and reclone repo but this time it doesn’t work. I’m in process of updating from 4.9 to 4.10 to see if that fixes problem so I can’t get machine ID right now.

Updating to 4.10 did not work. I have to install some debug tools to get stack trace but I’m guessing its same thing.

I updated to include machine id.

It sounds like something got corrupted in that original crash when you tried to Play in Editor. If something was trying to save at PIE, and it crashed, it’s likely it was only partially saved, and if it’s in map loaded when opening project, it could be causing this.

I would first try reverting to a pre-crash map, if possible. If that doesn’t work, you might need to start removing .uassets from project’s Content folder one at a time in windows explorer until you can open project, to at least narrow down which assets are causing crash on startup.

easiest way to at least get back into project, though, is probably to change editor startup map. You can do this by going to project’s Config folder and opening DefaultEngine.ini file. Search for “EditorStartupMap” and change path to an engine map, like “/Engine/Maps/Entry” and then try to open project. From there, you may need to recreate your map (trying to open it will likely crash editor, though that’s worth trying as well).

I created a new project and am slowly adding things in from old project. So far so good but I have a question, when playing a game in a separate PIE window and I hit ‘X’ button to close window, does that gracefully close game or is it a hard quit and something that should be avoided that could cause processing interruptions like this?

It gracefully stops PIE. You should be able to see this in log, if you watch during PIE. It sounds like there was a different cause for that crash, but I don’t see that in reports with Machine ID you sent.