Download

UE4 don't like one vertex in my mesh

Hello. I have a problem with my mesh. I want to say right now that I cannot upload this mesh here

I wanted to ask you for your help. This is one of many, many meshes that I worked with and only this one is causing problems. I received info that it is because, UE4 don’t like one vertex or edge.

Mesh works fine from “graphic” point of view, looks nice, proper import into engine, works with blueprints, but when you try to compile you receive this kind of error:

(…)
do {
checkSlow( e == FindEdge( e->v0, e->v1 ) );
checkSlow( e->v0->adjTris.Num() > 0 );
checkSlow( e->v1->adjTris.Num() > 0 );
(…)

I also received location of this weird vertex/edge but if I look at this positions in Maya or Unreal there is nothing, literally empty space

I also tried checking/welding/fixing/optimizing this mesh in Maya, Max, Blender and Zbrush and still, UE4 have problem with this one mesh and I am kinda out of ideas

Maybe anyone have any kind of idea ? Really, I would like to hear the most crazy ideas because I am empty