UE4 doesnt show compression settings for RenderTarget2D BP

I am trying to use compression settings for a RenderTarget2D Blueprint (It is for a minimap), but the compression options in the Details pane are non-existent, and the Compress tool in the toolbar is greyed out. Help!!!

When you right-click onto your newly created RenderTarget2D, you’ll find the option to create a static texture for it.
After that, you’ll find Compression Settings inside this static texture. The tutorial you’ve seen is from 5 years ago before Unreal splitted that up.