UE4 Doesn't detect my second graphics adapter, why log only detect Intel HD?

Please help … I’ve searched everywhere … i have an AMD Radeon HD8760m in my along with the Intel HD 4400
but the UE4 seems to be detecting only the intel HD … so everything runs on the lowest performance…

my does that as well but as long as you have set your laptops switchable graphics to use “high performance” with UE4 it should automatically switch to using your AMD card once UE4 has loaded, if you want to check if its using your AMD card download the AMD system monitor and have it open when you load UE4 and you should see the switch.

Sadly i have set the switchable graphics to high performance for the editor and the launcher but nothing changes … i’ve also downloaded the latest drivers and from the dell website … alllll drivers that are available didn’t change something …
please tell me what is the model of your ATI and does it play games and open UE4 ??? and your OS as well

my GPU in this is a 2GB HD7670m and my OS is windows 8, it does play games and run UE4 but like you UE4 only detects the intel HD4000.

:confused: it seems like a very popular problem … i will try downgrading to Win 7 64-bit and test everything again … and will post here the updates

Installed windows 7 64-bit and i’m still facing the same problem :confused: :confused:

All games and other software are running on the ATi HD 8670m but only UE4 runs on the Intel HD 4400 … please any help

that’s weird as it should automatically switch once UE4 has loaded but there used to be a way to manually change which graphics adapter UE4 uses, check this thread: Multiple Graphics Adapters (related to 4.1 QFE / very low fps rendering) - Community & Industry Discussion - Epic Developer Community Forums, it has the instructions how to do it, I don’t know if it still works as I haven’t tried it in a long time, hope that helps.

Are you all getting your drivers from AMD and Intel or from the manufacturer? Many of the Switchable Graphics setups require forked versions of the graphics drivers that are only available from the manufacturer’s websites.

Specifically for you Inspiron 15R-5537, see here.

I’d recommend using these with whatever OS your shipped with as that is probably what the manufacturer is expecting you to be using when they customize these drivers.


EDIT: Just saw that you downloaded them from their site. As much as I wish we could help in this case, the GPU switching has nothing to do with the Engine itself. UE4 is only detecting the Intel HD Graphics because that is all that is active at the time.

I don’t know how you people post an answer that doesn’t solve the problem and mark the Question as solved !! …

Hi AbdoEmary,

We are looking into some options that would allow us to force AMD Catalyst Control Center and Nvidia Optimus to use High Performance(discrete graphics).

I’d previously entered two Jira Tickets for more investigation (UE-20571 - Nvidia, UE-20574 - AMD).

If there are fundamental problems with the drivers though, these won’t have any effect. Example: There’s a known issue of Nvidia Optimus failing to recognize 64-bit software in some cases.