UE4 doesn't build a plugin.

Hey, folks.

I’m trying to install a GitHub - midgen/UnrealFastNoise: Modular, Blueprint-friendly noise generation for UE4 to my project.
But it seems like UE4 doesn’t compile it.

The steps I’m doing:

[The path where UE4 is installed: C:\Program Files\Epic Games\UE_4.18]

  1. Cloned UnrealFastNoise repo to C:\Program Files\Epic Games\UE_4.18\Engine\Plugins\Developer\UnrealFastNoisePlugin
  2. Created a new “Basic Code” C++ Project (MyProject2)
  3. Enabled UnrealFastNoisePlugin in UE4 Editor and restarted it.
  4. UE4 Editor cannot be restarted because of: “the followin modules are missing or build with different engine version: UE4Editor-UnrealFastNoisePlugin.dll Would you like to rebuild them now?”

Selected “Yes”, another error - “MyProject2 could not be compiled. Try rebuilding from source manually”.

Infromation from log file Documents\Unreal Projects\MyProject2\Saved\Logs\MyProject2.log:

LogInit: Warning: Incompatible or missing module: UE4Editor-UnrealFastNoisePlugin.dll Running C:/Program Files/Epic Games/UE_4.18/Engine/Binaries/DotNET/UnrealBuildTool.exe MyProject2 Development Win64 -project="C:/Users/Rewlion/Documents/Unreal Projects/MyProject2/MyProject2.uproject" -editorrecompile -progress -NoHotReloadFromIDE Creating makefile for MyProject2 (.uproject file is newer) @progress push 5% @progress pop Target is up to date Total build time: 4,09 seconds (NoActionsToExecute executor: 0,00 seconds)

LogInit: Warning: Still incompatible or missing module: UE4Editor-UnrealFastNoisePlugin.dll LogExit: Preparing to exit.

  1. Tried to rebuild MyProject2 from Visual Studio 2017 : no errors ,plugin didn’t compiled (didn’t find any plugin’s *.lib)
  2. redo step 4, same result, same error, same log.

MyProject2.uproject contains: { "FileVersion": 3, "EngineAssociation": "4.18", "Category": "", "Description": "", "Modules": [ { "Name": "MyProject2", "Type": "Runtime", "LoadingPhase": "Default" } ], "Plugins": [ { "Name": "UnrealFastNoisePlugin", "Enabled": true } ] }

But, I’m able to successfully build it manually with RunUAT (C:\Program Files\Epic Games\UE_4.18\Engine\Build\BatchFiles\RunUAT.bat)

The question is - why isn’t it builded from VS2017 or from UE4 editor?