Ue4 doesn't apply DPI scaling

Hello, I am creating a mobile game, but when I start the game in a device the UI DPI Scale doesn’t work, so buttons, images etc: are too small or too large.

These are my user interface settings:

And here there is the scale rule: UIScaleCurve=(EditorCurveData=(PreInfinityExtrap=RCCE_Constant,PostInfinityExtrap=RCCE_Constant,Keys=((Time=480.000000,Value=0.220000),(Time=640.000000,Value=0.770000),(Time=719.000000,Value=1.000000),(Time=730.000000,Value=1.000000),(Time=749.000000,Value=1.041600),(Time=760.000000,Value=1.041600),(Time=767.000000,Value=0.811446),(Time=778.000000,Value=0.811446),(Time=1080.000000,Value=1.500000),(Time=1536.000000,Value=1.580000),(Time=8640.000000,Value=8.000000)),DefaultValue=340282346638528859811704183484516925440.000000),ExternalCurve=None)

Is all correct in fact when I see the widget from Ue4 editor is correct:

But when the widgets run in the same device of the editor: S4 1080 x 1920 the scale is wrong:

I noticed that if I change the values (1.5 → 2.5, 1 → 1.66, etc) the result doesn’t change it’s as if engine doesn’t read settings.

Sorry for my bad English. Thanks

I feel your pain …. I have struggled with this issue in the past and it is a headache.
I have found that if I wrap my canvas panel in a size box and then wrap that size box in a scale box I can force the game to display in the resolution I wish. Use the desired aspect ratio when entering the resolution and it will force the game to that aspect ratio.


Here is my DPI scaling settings. I don’t use/need them so they are set to default.

Thanks Filibuster, your idea is good but is obvius that it is a good idea when the heightscreen is 16:9. But for example when the heightscreen is 2:3 (iphone 4, iphone 5, iphone 5c) unreal creates two black vertical bars. I solved by changing the application scale to 2.192. 2.192 is the unique costant that I found.

Anyway, your method is right, so your answer is correct.