UE4 - Disk space management issue

Possibly a silly question but for the life of me I can’t figure out how you assign Epic games launcher to download it’s marketplace assets to an external drive? I’ve run out of space on my main drive so tried reinstalling the launcher from scratch by changing it from C:/ to my external but then it came up with an error and wouldn’t let me install the engine. Frustrating. So I conceded and thought well I have enough space for the engine itself but no assets etc I’ll just install that so it works and tell it in settings to save anything additional elsewhere but I can’t find any settings to change the location of where the downloads go. Doesn’t give me that option just downloads to C drive because that’s where the launcher is.

I don’t know why they just don’t give you the option of where you want to download to before you download. If anyone knows a work around for this that would be very helpful.

The sample content is downloaded into your “vault” -> \Unreal Engine\Launcher\VaultCache. From there you can move it to your other drive + delete it from the vault to save space.
I dont know if there is another way to solve that problem (you could move your vault folder -> https://answers.unrealengine.com/questions/74101/vault-on-43.html), but I think epic games is working on a solution. :slight_smile:

Cant the default folder path for the vault not simply be pointing to a mounted location elsewhere…?

you can redirect a folder in windows to point to external drive. I have Documents/Unreal Projects redirected to save space on system SSD. On mobile, but you can google it.

Yep, it’s possible -> the instructions are in my upper posted link :slight_smile:

Okay finally got the symbolic link to work and now it’s all good. Just had to read through those instructions very carefully. Thanks a heap fighter!