UE4 crashing on launch

Hello! I’m attempting to run UE4 on my new PC, but it instantly crashes on startup with the header “Entry Point Not Found” and the message “The procedure entry point D3DReflect could not be located in the dynamic link library D3DCOMPILER_43.dll.” Any idea what I’m doing wrong?

Hey pointycat-

Have you tried restarting your computer? If there is a problem with the file not being properly then a restart may be able to fix it. If that doesn’t work you may want to try updating/reinstalling DirectX. As a last resort you may need to redownload/reinstall the editor.


Hi ,

Unfortunately, after doing all of this (wiping everything clean, rebooting, a fresh download and install), I still get the exact same error message.

Is this happening when trying to open the launcher or is it when trying to open the actual editor that it crashes? Could you post the DXDiag for your machine as well?

The launcher. I can’t even download the full editor – I download the initial small setup file, get the launcher icon, click it, then crash. I’ve attached my DXDiag.link text

Hi pointycat,

Please try the troubleshooting steps linked below for the “Can’t install the Launcher” section. Afterwards if the issue is still present, please post your logs.



Hi TJ,

Running it as administrator resulted in the same error. Re: the wiki’s instructions, I put the msi at the C: drive root, and used “msiexec /i C:\UnrealEngineInstaller-1.8.1-2322947.msi /L*V C:\UnrealEngineInstallerLog.txt” (changing the placeholder name for the actual file name). Windows responds with “Error opening installation log file. Verify that the specified log file location exists and is writeable.”

I don’t have enough info yet to make a proper assessment but I suspect the DirectX installer is failing to overwrite an existing D3DCOMPILER_43.dll that was somehow corrupted on your system. I’m going to ask for a log file so I can verify and give you some steps you can follow that should get you past this error.

First, please attach the following log file to this thread: C:\Windows\Logs\DirectX.log
This log file should show us why the DirectX installer chose to not overwrite the existing dll.

Next, here is a possible fix for the issue:

  1. Check to make sure you have this file: C:\Windows\System32\D3DCompiler_43.dll. If you do, continue to the next steps.
  2. Uninstall Unreal Engine
  3. Backup this file C:\Windows\System32\D3DCompiler_43.dll by renaming it to D3DCompiler_43.dll_BACKUP
  4. Install Unreal Engine. The launcher should start at this point.

Hi pointycat,

We haven’t heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you’re still experiencing this issue, please try the possible solution 0xDEADBEEF provided above.




I have solved coping and replacing the file d3dcompiler_43.dll in C:\Windows\System32 into UnrealEngine\Engine\Binaries\Win64

i have the same problem nothing out of this list helped me…
Epic if you are reading this PLEASE HELP