Download

UE4 crashing constantly since 4.16.0 (4.16 beta worked fine...)

As the title says,

UE4 constantly crashes every few seconds when you are doing stuff with UMG, even on empty widgets, with nothing in them.

The engine crashes when you click “Designer”, sometimes it also crashes without any reason, then again it crashes because i have not clicked anything for the last 5 minutes.

I Stopped counting how many crash-reports I already sent today.

Do we have a fix for this? because this currently stops me from rolling out a big patch for my game, because this is the last stuff that I need to do.

Do you have an AnswerHub post or Crash Reporter link? Any information would be useful, we would obviously like to fix this!

The same here. Crash occurs quite often :frowning: I have already reported!

Dear JamesG, thank you for your reply.

I currently do not have an AnswerHub post because i can not precisely describe the reason for the crashes. (It mostly happens when you try to animate widgets in UMG, sometimes when you switch between Designer and EventGraph)

I also do not know what a Crash Reporter Link is?
If you can explain to me where i find this, i will post these links. (there should be dozens of crashreports from yesterday alone.)

I will try to replicate it now, to get another report.

EDIT1: for now it worked… not sure why, looks like UE4 learned to “behave” over night? :stuck_out_tongue:

But since i am not the only one where this happened/happens there must be more to it then just UE4 having a “bad day” (especially since i restarted ue4 and my pc yesterday already, just to be sure it really is UE4s problem.)

It must be something 4.16.0 specific, since it did not occur with the beta-versions.

I’m running into the same issue. I’m working with a project that originated in 4.4 and has been converted multiple times. 4.15 was very stable but ever since migrating my project into 4.16, I can only work in UMG for 20-30 minutes of work in before the editor crashes. I don’t know enough about what’s causing it yet - I will report back when I have something reproducible.

Hi Yaeko.

I’ve reviewed your submitted crash reports, and identified that you are experiencing this issue. Unreal Engine Issues and Bug Tracker (UE-45498)

If you are able to identify a definite set of reproduction steps to cause this crash to occur, please let us know.

Thanks

Thank you for your reply, I do not have a definite set of steps, but I can provide you with additional information and a video of what I did when the engine crashed. (I decided to record the engine, because i already had a feeling that this was a nasty bug.)

I hade the sequencer open, on the 2nd screen, together with the levels window, also on the second screen. (i can not remember if there was something in the sequencer or if it was empty)

I was playing around with UMG-Animations a bit, setting keyframes, scrolling the timeline -> crash.

Video (crash happened when the video ends, you should have the crash report that belongs to it): Untitled.mp4 - Google Drive (cut to only show the last 15 seconds, but i have more (before the crash), if needed)

My problem with replicating this crash is:

  • Crashes appear totally random at times (without any understandable reason, just like when i made a right mouse click into the timeline)
  • They currently do not appear, I tried to “force” the engine to crash, without any results.
  • sometimes the engine crashes 30 seconds after I launch it, sometimes not for 20 minutes.

At times I was so scared that I saved everytime i clicked something :rolleyes:.

I really want to help, but that is all information that i have, i am sorry.

EDIT: Please don’t judge me on the stuff i am doing with/in the engine, its just messing around.

Thanks Yaeko.

Our engineers believe they have identified the issue and submitted a fix for it. We are targeting an upcoming hotfix to include this fix.

Cheers

The material editor crashes all the time too. I can’t enter it for more than a few seconds. The Render thread keeps trying to access shader resources, but there are asserts all around those resources to only be accessed from the game thread.

msvc 2017, windows 10. I heard from someone else that the pre-built editor from the prepackaged install does not do this. Only when you build from source.

https://answers.unrealengine.com/questions/605843/assert-failure-when-creating-new-material-node.html

I agree anyone else having odd crashes? Im getting them on just calling GetWorld info like 5 seconds after the world is loaded.

Its called 5 seconds after the actor has been created fully

FWIW, I tracked down the issue, for me, was only occurring when editing animations in UMG. Specifically, dragging an existing keyframe to a different time. However, 4.16.1 seems to have resolved it!

Thanks, guys - you’re the best!

Looks to me like AAIController_Base is nullptr, otherwise it wouldn’t crash where it has.