UE4 crashes when I click anywhere on the Content Browser


Whenever I open any project (new or pre-existing one) the engine opens up and run fine till I click anywhere on the content browser, even the empty parts. When this happens Unreal Engine stops responding and never responds again, and if I try to close it using the task manager by ending the process Windows (OS) stops responding, and I have to directly turn off the computer through the power button. This also happens randomly sometimes and whenever I build the lighting the swarm agent opens and all but the progress bar gets stuck at 19% but then I am able to close the engine via task manager. Tried upgrading windows, resetting it, clean windows install doesn’t help too, tried downgrading from 4.25 to 4.24, reinstalling UE4, nothing seems to work.
Specs: i5-8250U, 8gb, Integrated Graphics, Windows 10 ofc. I know there is no GPU but I have run UE4 on 4th gen i3 Graphics so I am ■■■■ sure that isn’t the issue. Someone please help this issue has not been allowing me to work on anything and everything’s stuck.

i think it s really because of the integrated graphic chip. maybe an older version like 4.18 or 4.19 would work. (on my laptop, even with a dedicated GPU, i have graphical glitches since 4.23)

i’m having the same issue. i am on a laptop but i do have a dedicated graphics card, GTX1050ti. i’ve used this computer for a while now and no issue until recently. any help or ideas are appreciated.