UE4 Crashes on launch and Library tab

When I press the launch engine button, the engine loads for a few seconds before crashing. It’s the same with all the versions I have installed. 4.3.1, 4.4.3 and 4.5.0. It also crashes when I press the Library tab. Then it just immediately shuts down and brings up the bug report window.

Dump file

Hi Hropt,

Can you bypass the Launcher and open the .exe file for the editor?

C:\Program Files\Unreal Engine\4.5\Engine\Binaries\Win64\UE4Editor.exe

If you can open the editor this way, then it is a Launcher issue. Please follow the link below and try the troubleshooting steps. If the issue persist, post your ‘Verbose Logs’. They will help us track down the issue.

If the .exe doesn’t open for you, please post back here to let us know.

Hey :slight_smile:

Clever me tried to reinstall the whole thing last night. Now I get the same error, just no engine installed.

I tried to bypass the launcher before that though, with no luck. I tried the troubleshooting link as well (pretty sure I did that before I tried to reinstall it last night as well), to no avail. Logs are below.


Usually if it is just the Launcher the .exe will open fine.

Could you also post your ‘dxdiag’? If you’re on Windows, just go to the Start Menu and put ‘dxdiag’ into the search bar. Click ‘Save All Information’ and post the text file.

Here’s the dxdiag.

link text

Okay, try download the Windows Service Pack 1. It’s not listed in your dxdiag and missing that driver update can sometimes cause issues.

If that doesn’t work, another possible issue could be with running UE4 on a on-board graphics card. We recommend using a NVIDIA GeForce 470 GTX or AMD Radeon 6870 HD series card or higher. Even if the service pack works, you may experience longer load times and a low frame-rate while using the editor. On-board graphics cards are quite limited.

Starting the download now, connection is a bit slow so I’ll have to wait until tomorrow morning to install. I’ll try to get it installed and test it before I have to leave in the morning.

I’m running it on a laptop with a Geforce 770m GTX. Shouldn’t that be good enough? It’s not great but it’s done okay so far, at least.

I’ll let you know how it goes.

Installed the service pack. Still the same error. Managed to install the latest launcher which downloaded the 4.5.1 engine and installed it without me having to click on anything. Still can’t bypass the launcher though.

Ah, okay. I didn’t see your Geforce listed on your dxdiag. This could be because of a program called Optimus. If your using it, it will sometimes only list your integrated graphics card.

So one last thing before I get our Launcher team looking into this. Could you make sure that your graphics card driver is up to date? Also, make sure that you aren’t using the beta driver. They can sometimes conflict.

Updated driver, still nothing.

Try launching the editor from the .exe again and once it crashes, get the LOG files from that crash. I would like to compare them to your previous LOG files.

The reason being is if it crashes from the .exe then it shouldn’t be a launcher issue but from your previous LOG file it is definitely failing at the Launcher portion of the start-up.

I noticed that the new engine was installed in a different folder, Epic Games instead of Unreal Engine. Not sure if that matters, but the new engine doesn’t generate the dump files, just the the text file. It’s a lot bigger than the other text files generated though (about 1,3 mb).

link text

I think you may still have the bit of code in the DefaultEngine.ini from getting your Verbose Logs from earlier. If you take it out you should get the regular LOG files. You will know if they are still the Verbose logs by word searching verbose in the file and/or they are generally much larger.


Hi Hropt,

A quick check, this crash can sometimes be caused by a corrupt or 0 byte png file in one of your projects on your machine.

I’m afraid the only way I can think that you will find it is if you go check all of your projects that you have that normally show in the launcher under “My Projects”, to see if they have a broken png file next to it’s uproject file, or the file at [Project]/Saved/AutoScreenshot.png

If my suspicion is right, then the project browser of the editor for which the particular project gets listed in will also crash in the same way when trying to list the projects.

Hope that helps!<\br>

Just got the logs to work again.

link text

Hm, didn’t work. I’ll go through the files again to make sure I got everything.

The problem was that the image next to the uproject file was missing. Copied image over from the project that still had one and gave it the same name as the uproject file.

Thanks :slight_smile:

Got it working again. Thanks for the help :slight_smile:

Ahh interesting! I will add an issue to investigate reproducing and fixing that case! Thanks for reporting back. Glad you are up and running :slight_smile: