Download

Ue4 Context flicker and Maximized editor turns to black screen error

I used Unreal engine version of 4.26.2 , 4.27.2 and both version has acquired this error
(right click menu, context, …etc all menu flickering and maximized editor turns to black)

This error casued by when I turn on the ue4 passed 15~20minutes. normally

Below way is I already done this

  1. I already Uncheck “Enable Window Animations”.

  2. I turns off MFAA.

  3. My graphic driver version of latest.

  4. I used before this registry"After updating to NVIDIA Game Ready Driver 461.09 or newer, some desktop apps may flicker or stutter when resizing the window on some PC configurations | NVIDIA" but If I use this my maximized netflix be flickering when I watching netflix.


My Graphic Card: NVIDIA GeForce RTX 3070
Display : 2560 x 1440 (144Hz) - HDR support

Did you try the registry fix from NVIDIA’s forums? I had this problem, and I think that registry download thing fixed it. It was that or something else. But others have had it fixed by downloading and installing that reg hotfix.

A few things to check, though, are in your NVidia Control Panel. By default, UE4 operates in 10bit color mode with 2bit alpha. In NVidia Control Panel, under Change Resolution, there’s settings for color. One is Output Color Depth, and if it’s not set to 10-bit, change it to 10-bit instead of 8. Check Dynamic Range, Color Format, and set those to something different too. Range should be at the Full setting, and Format is normally RGB, but some people have fixed that kind of error by changing to one of the YCbCr options. Check your monitor too, to see if it is actually running in HDR mode or not. My LG 2K monitor has a mode that simulates HDR, but it’s not actual HDR. It has actual HDR too, but I changed my settings to HDR Off. True HDR is apparently 12-bit color depth, which is actually Unreal’s 10bit RGB 2bit Alpha. The closest to it is 10bit color depth (output, not desktop), as far as I know, and it may be it because it’s simply omitting the 2bit alpha part. Ensure Windows has HDR turned On too. Turn the monitor to HDR On, so everything is in HDR mode, and it’s all syncing / compatible. If not using HDR, then turn off HDR for everything except Unreal and see how it works.

Thanks for answering
But that NVIDIA registry you said is looks like my question number 4.
I think that is working but when I used it my maximized netflix window be flickering :frowning:

Did you also use the next one? It re-enables what was turned off by the one you did. What are you using to watch Netflix (internet browser, or app)?

Actually, there is no problem if you use mpo_disable(for UE4) and mpo_restore(for Netflix) alternately. However, there is a disadvantage that a reboot or logoff is required to apply the registry.