UE4 - Can´t use more than 5 textures per landscapes materials or grey patches appears, why?

Hi, i have read that a single material canot use more than 14 textures, in my case i canot use more than 10 textures, after this number, a grey patch appears in the landscape, this limits are not described in documentation do, i found it forums trying to understand the grey patch in ladscapes.

The problem is that 10 means i can only use 5… because each texture also requires a normal texture, then if i have a large landscape, painting becomes a very repetitive un-natural thing, becase i can only have 1 Grass, 1 rock, i ground, 1 wet and 1 dirt texture… and large landscapes look super fake now with this limitation because if you see a real landscape, even Grass has color variations.

What can i do?

This is the wrong forum for this question. Should be in the Rendering section.

But yes, there is a texture sampler limit per landscape component/section. You can get around that limit in your material by going to all of your Texture Sample nodes, and setting “Sampler Source” to Shared:Wrap .

1 Like

I use a BP platform to configure material and texture nodes. I´m not asking about how to add a new texture or blend materials, but why the material BP canot handle using more than 10 textures or patches appear in the landscapes, that´s a BP communication problem, or BP limit issue not a rendering problem.


my cousin and I, in our learning, both wound up creating a landscape material. he tweaked his up to try to incorporate some of the modularity I had made while keeping some of the other bits his tutorial had shown him.

long story short, my 8 blend layers worked but with his material they didn’t. I went and changed all of our texture params Sampler Source like you said and everything is showing up.

thanks a million dude.

edit: if this information doesn’t exist in the official documentation for landscape blend layers, it absolutely should. the mere fact that if you set it to wrap you can use an unlimited number is insanely powerful.