Download

UE4 - Cameras and lights are visible as spheres during in-game sequences, why?

Hi, I’m working on a Cinematic Sequence, this level does not use “GameMode Override” because the sequencer is the one triggering everything, But… I canot remove the main editor camera, it appears in the scene as an sphere. If I use the editor camera to move an object, whenever the sequence starts, in that location where my camera editor was left a grey sphere appears, this happens all the time with Sequencer, my only solution for now, has been to move my camera off-screen, either down or up, so when the sequencer starts playing, the sphere is no longer in there… not a real solution.

I wonder if there is a solution for this issue? I read in another post, that this can be solved, actually by setting the Game Mode to “none”, but I do have it to none, and the camera editor sphere keeps appearing in the scene In-Game.

Updating this issue, now after playing the sequence, light actors also display an sphere In-game, these lights are just point light actors taken from the modes panel… not sure why every actor has this grey sphere… ¿why would I add a light to a sequence and once I play I’m able to see the light actor also as an small grey sphere? this grey sphere representing the actor doesn’t even appear in the viewport, so what is the point of watching them In-game, I still can’t fix it, and I canot just move lights and hide those grey spheres like I do with my cameras…

Please help

Did you solve it? I have the same issue. Every time I render my sequence a mysterious sphere is there, occluding my mesh.

Sounds like your scene roots are being captured, I might be wrong though.

I think so, but I have no idea how to fix it… so my smart solution is to handle cameras and meshes in a way that they kind of hide from the camera frame… but, that’s a problem, because at least in my case, I need to change the way I shoot my sequences, which are a lot.