UE4 asset Window will not opening

Okay, so it started when I was in my level and I deleted a folder with assets in it that I don’t need, when I did that it deleted the assets in the folder but not the folder its self. So I then deleted the empty folder and now when I try to open up a Texture, Asset, Blueprint, etc, it makes a small window (with UE4 Emblem in the center) in the bottom tab and never pulls it up when I click it. Could it be a Firewall? Whats causing this? And how do I fix this?

Come to find out your are suppose to right click on the folder that’s empty and use something called a re-director. Well I didn’t use that and now this is happening when I try to open something up.

Please help! Thanks.

Are you sure it’s not showing up somewhere, but really really small? I had a smililar issue where windows would open up, but be really tiny. So I had to drag them bigger again.

Ya but it still does it.

Ya I have checked and that’s not the problem. Thanks for the reply :wink:

It acts like the engine\software is curupted because it even does this to my other levels from a good while back that I have not touched in a while. And I even got a level and put it on another computer and it works just fine and its window even pulls up just on my computer it does not want to come up. So my guess is the software glitched and damaged its self. I even tried going to Change/Repair a program and the repair didn’t work. I’m guessing that’s because it only repaired other stuff not really the glitch. Not going to like this it’s a pain but do I have to uninstall UE4 and reinstall it?

Ah, that’s not good… If that is the case it would be a good idea to verify the engine files. When you say Change/Repair, do you mean from the launcher? If not give this a try:

Open the Launcher (make sure the editor is closed first) and go to the Library tab, then click the small “V” down arrow next to the editor version you are using (in the blue tiles) and select Verify.

That should go through all your files and if any are missing it will re-download them. Hope that helps! :slight_smile:

Like if I go to my PC settings their is a thing called uninstall/repair program I did the repair but did fix it so I’m thinking I have to uninstall UE4 and reinstall it. How come UE4 folders are so delicate? They seem to glitch really easy. This happened to me once 5 months ago because I renamed a folder.

but did not fix it* I met.

Hey dotcam! So do you think this is related to the engine and the engine might have got damaged? And would deleting UE4 off my computer and reinstalling it fix it?

If you were deleting content that you created, then no the engine shouldn’t need to be re-installed. But what you’ve said above (the part about it opening a blank window) does sound like an engine issue.

So first, what did you delete, and where was it located (were the files in your project)? If so, then you might need to either open an earlier backup of your game and migrate the assets you created out of the project that is not working, or migrate them to a new clean project.

Try doing the Verify process I posted above first, but if that doesn’t help and your project (copied from your PC to the other PC) opens on another computer just fine, then I would go ahead and re-install the engine. That’s a pretty good indication something went wrong. I have never had that happen, but have seen others posting with a similar issue.

Alright, It started when I delete a starter content folder and a third person shooter content folder. I deleted them by right clicking over them and clicking delete and it deleted the assets and everything in them but not the actual folder. That’s when I deleted the empty folders thinking that it wouldn’t harm anything and then that’s when this happened. And none of those assets that were in those folders were never in use in the actual level.

Okay, so I did the verify think you said to do on the launcher and that didn’t work. So I’ll try the engine reinstall.

One thing you can try is right click on the “Content” folder in the Content Browser and choose “Fix up redirectors”. Once that is done you should be able to permanently delete the unwanted folders. See if that makes any difference.

If that doesn’t help and your project is relatively small, it might be easiest to create a new project and copy the blueprint, mesh, and material assets manually in Windows Explorer to the new project.

Hope that helps! :slight_smile:

That’s whats weird is all of my levels have became affected and I cant get the window to open when I try to open up a blueprint, asset, texture, etc in them. So that’s why I think its the editor/engine that has been corrupted. The levels are fine because I’ve put them on another computer with UE4 and their asset windows open up just fine. Even if I make a new level it does the same thing.

Thanks for taking the time to guide me through this. :slight_smile:

YAY GOT IT TO WORK:D:):):)!!! So I backed up my levels and I uninstalled UE4 and re-downloaded it and at first it still wasn’t working. So I right clicked on the window that was in my tab and not opening and when I did that their was an option to restore, close & open. But it disappears after like a second. So what I did is I right clicked and clicked restore before the option disappeared and I minimized the UE4 project editor window into my tab I then started rapidly box selecting in my desktop and I then managed to grab the invisible window in my desktop and when I grabbed it, it suddenly appeared. It was minimized pretty small but I then dragged it bigger and that fixed it!!! So basically it was opened in the background but it was invisible, so I minimize the editor window into my tab and start box selecting at my desktop and you should be able to grab it. So then I put my projects back in and it still works perfect!

Anyways thanks for taking the time to help me out! :slight_smile:

Also could you get word to the UE4 Dev team about this glitch and maybe they can get a patch on it, if you get the chance? Thanks :slight_smile:

I had the same problem and used Window/Reset Layout.

It fixes the problem very swiftly.

1 Like

Give your computer a reboot to refresh the memory, sometimes this can cause windows become invsible.
Unreal Engine also has a problem of allowing the mouse cursor to move all around when in the PIE
Run game Mode and clicking on desktop icons behind the window, it shouldn’t be doing that… When all it should be doing is only moving the mouse cursor freely inside the game window and not be active moving also behind the game window on the windows desktop background unless you hit ESCAPE to exit the
game and go back to the editor.

Thank you! This worked instantly :slight_smile: