UE4 ART fails during rig build

Ok, so I’ve dug around and can’t figure this out.
ART keeps stopping at 20% when I try to Build the character rig. I managed to do this successfully before with the same computer and I haven’t messed with my maya 2014 install, but at the time I was using the 4.5 version of the tool. I tried switching to the 4.5 release of ART, as well as the version in 4.8, AND the latest/greatest form the dropbox on the big FAQ/bugs thread, but the result is always the same.

Here’s a pastebin with my script editor output: UE4 Maya ART script editor output - Pastebin.com

One thing I don’t understand is at line 927
File “C:/Program Files/Unreal Engine/4.0/Engine/Extras/Maya_AnimationRiggingTools/MayaTools/General/Scripts\ART_skeletonBuilder_UI.py”
But why is it looking under my 4.0 install? Shouldn’t it be looking under Program Files/Unreal Engine/4.8/Engine…etc?

Before and after that line is various errors relating to leg components. 935: result_leg_ball_l.rotateX has incoming connection; 922: # Error: The orientConstraint ‘fk_leg_calf_r_orientConstraint1’ has no ‘jo’ attribute. #
Same errors for the same parts on r and l side.

867 to 910 it has a bunch of warnings about name clashes. Suggests using namespaces, but I have checked and found no options to set namespaces in the ART tools. Am I supposed to reference my geo with namespaces before building a rig? I tried referencing it, but it still stopped at 20%

Thanks in advance for any suggestions, sorry if I overlooked something obvious, but I’ve been sitting on this for 2 days and am just drawing a blank.

Hello, we are encountering the same problem (Maya 2016, UE4.11). Did you manage to find a solution for this?

Many thanks

Hey, just seeing this. The answers notifications don’t work super well.
So, I had this happen on a few occasions and there seem to be multiple ways it can break down. First thing is to note that the errors were a red herring. They weren’t ultimately the cause of it breaking down, just a symptom.
One thing that fixes the rig build was to use .mb files. It apparently just doesn’t work with .ma and as far as I’ve seen, nothing in the docs ever points this out.
The other thing is making sure it’s looking in the Tools Path.
It’s been a while, so I can’t remember the other specifics. But in general it also has to do with close adherence to the order of operations. The way they show you to do things in the tutorial videos is exactly how it’s meant to work and even seemingly innocuous deviations can break it down. I’d recommend testing it by just clicking through and making a dummy rig(without binding any of your geo to it) just to make sure it’s not your order of operations that’s messed up.
Hope this is informative to anyone that stumbles upon this issue in the future.

When I would get errors on on the build, I would export as an ascii. Open a new file, import (Not open) the ascii, then open the artools menu, and continue. I think that really deletes unused or unknown nodes.