UE4 animation interpolation method works in a wrong way!

UE4 animation bug:

UE4 always interpolate animation in an incorrect way. When animation contains per-frame-stepping keyframes, it comes into a big issue. The bones can’t translate to their actual positions on every keyframe.

— Test FBX file: anim_interpolation_bug_fbx.rar [Download Here][1] —

However, Unity can handle it correctly, even with interpolation too. It’s apparently not good news for UE4! So, Epic, please fix it !!!

Unity5 animation interpolation resault:

Hi Awesome_Junior_Miss,

Can you please send me your blend file? Frequently people run into issues with Blender’s export settings, so can you send me a screenshot of your export settings too?

-Matt W.

blend file: Download Here

Actually, this bug was discovered by others who don’t use blender at all. Then I tested it making sure if it was a bug and posted it here. So I think it’s not a 3D app dependent issue. At least, Unity performed properly using exacly the same FBX file I uploaded here. You may also download a free version Unity 5 and make a quick test.

Hey Awesome_Junior_Miss,

This bug seems to crop up starting in 4.9. I’ve entered UE-29112 in our system for you. It’s not a pretty workaround, but I’ve successfully imported the fbx with 4.8, then migrated it to a later engine version.

-Matt W.