Download

UE4 animation compression Question

Hi all,

I am exporting fbx’s into UE4 with odd results that I am trying to understand.

I have taken a fairly simple 900 frame animation, baked it, exported it, and imported into UE4. In UE4 it is a 900 frame animation. Cool.

But I have another animation using the same skeleton that is 50 frames and more complex in it’s movement and when baked, exported and imported into UE4… UE4 says it is a 4 frame animation (and it looks like it… all of subtlety is gone). I think I understand the compression and interpolation that occurs in UE4 when bringing in an unbaked animation… but I don’t understand why UE4 is compressing a 50 frame baked animation down to 4 frames.

Any help is appreciated.

Thanks.

I don’t know why it would import one FBX differently from another if both were exported with the exact same settings, but you can try correcting this by setting the import range like so (filling in the appropriate number of frames, of course):

Hi Steve,

Thanks for the response and suggestion. My issue wasn’t that the whole animation wasn’t importing into UE4. I would get the whole animation. The issue is that UE4 would compress it down to 4 frames (from 50 in Maya) and interpolate between those 4 frames (with obvious loss of detail). I could take another animation, with the exact export/import settings and this would not happen. i.e. I would export a 200 frame animation from Maya, and when imported into UE4 the animation would be 200 frames with detail intact.

I did eventually get my troublesome 50 frame animation to import as a 50 frame animation to UE4 however! What I discovered is that I had keys beyond the timeline in my Maya file. I had keys on -10 and keys all the way out to +950. I also had my Maya time frame end time set to 950, and my playback time set to 50.

So I trimmed all keyframes to the 0 - 50 frame animation, made sure my begin and end time was set to 0 - 50 and re-exported. I set the UE4 importer to read the length coming in (setting the animation length in your above image to grab from the incoming animation). The animation imported into UE4 as 50 frames with the desired detail intact. I am not wholly sure why… but I now have a solution to my problem. I will read through your documentation on importing and exporting animation thoroughly to fully understand the compression that UE will put on incoming animation. Thanks again! :slight_smile: