Download

Ue4 Android Game Compilation | Ue4 4.23

Hello guys, I have got stuck on one problem with compilation

Here you can find a log file and the last strings.

UATHelper: Packaging (Android (ETC1)): ********** STAGE COMMAND COMPLETED **********
UATHelper: Packaging (Android (ETC1)): ********** PACKAGE COMMAND STARTED **********
UATHelper: Packaging (Android (ETC1)): BaseApkName = D:\Ue4Projects\Quick\USSR_Clicker\Binaries\Android\USSR_Clicker-Android-Shipping.apk
UATHelper: Packaging (Android (ETC1)): Creating D:\Ue4Projects\Quick\USSR_Clicker\Saved\StagedBuilds\Android_ETC1.obb from D:\Ue4Projects\Quick\USSR_Clicker\Saved\StagedBuilds\Android_ETC1
UATHelper: Packaging (Android (ETC1)): [1/1] Adding USSR_Clicker/Content/Paks/USSR_Clicker-Android_ETC1.pak to OBB
UATHelper: Packaging (Android (ETC1)): AndroidPlugin: Plugins\Online\Android\OnlineSubsystemGooglePlay\Source\OnlineSubsystemGooglePlay_UPL.xml
UATHelper: Packaging (Android (ETC1)): AndroidPlugin: Plugins\Runtime\AndroidPermission\Source\AndroidPermission\AndroidPermission_APL.xml
UATHelper: Packaging (Android (ETC1)): AndroidPlugin: Plugins\Runtime\GoogleCloudMessaging\Source\GoogleCloudMessaging\GoogleCloudMessaging_UPL.xml
UATHelper: Packaging (Android (ETC1)): AndroidPlugin: Plugins\Runtime\Oculus\OculusVR\Source\OculusHMD\OculusMobile_APL.xml
UATHelper: Packaging (Android (ETC1)): AndroidPlugin: Source\Runtime\Online\Voice\AndroidVoiceImpl_UPL.xml
UATHelper: Packaging (Android (ETC1)): AndroidPlugin: Source\Runtime\Advertising\Android\AndroidAdvertising\AndroidAdvertising_APL.xml
UATHelper: Packaging (Android (ETC1)): UPL: Engine\Plugins/Online/Android/OnlineSubsystemGooglePlay/Source/OnlineSubsystemGooglePlay_UPL.xml
UATHelper: Packaging (Android (ETC1)): UPL: Engine\Plugins/Runtime/AndroidPermission/Source/AndroidPermission/AndroidPermission_APL.xml
UATHelper: Packaging (Android (ETC1)): UPL: Engine\Plugins/Runtime/GoogleCloudMessaging/Source/GoogleCloudMessaging/GoogleCloudMessaging_UPL.xml
UATHelper: Packaging (Android (ETC1)): UPL: Engine\Plugins/Runtime/Oculus/OculusVR/Source/OculusHMD/OculusMobile_APL.xml
UATHelper: Packaging (Android (ETC1)): UPL: Engine\Source/Runtime/Online/Voice/AndroidVoiceImpl_UPL.xml
UATHelper: Packaging (Android (ETC1)): UPL: Engine\Source/Runtime/Advertising/Android/AndroidAdvertising/AndroidAdvertising_APL.xml
UATHelper: Packaging (Android (ETC1)): Target SDK Version 26
UATHelper: Packaging (Android (ETC1)): Using package name: ‘com.HSchrodder.USSRCLICKER’
UATHelper: Packaging (Android (ETC1)): GotStoreVersion found v1. (bUseChangeListAsStoreVersion=False IsBuildMachine=False EngineChangeList=0)
UATHelper: Packaging (Android (ETC1)): Writing packageInfo pkgName:com.HSchrodder.USSRCLICKER storeVersion:1 versionDisplayName:1.0 to D:\Ue4Projects\Quick\USSR_Clicker\Binaries\Android\packageInfo.txt
UATHelper: Packaging (Android (ETC1)): ====09.11.2019 23:53:46====PREPARING TO MAKE APK=================================================================
UATHelper: Packaging (Android (ETC1)): bBuildForES2: false
UATHelper: Packaging (Android (ETC1)): bBuildForES31: true
UATHelper: Packaging (Android (ETC1)): bSupportsVulkan: false
UATHelper: Packaging (Android (ETC1)): Requires at least SDK API level 28, currently set to ‘android-24’
UATHelper: Packaging (Android (ETC1)): ERROR: Can’t make an APK without SDK API ‘android-28’ minimum installed
UATHelper: Packaging (Android (ETC1)): (see C:\Users\Schrodder\AppData\Roaming\Unreal Engine\AutomationTool\Logs\E+Software+Unreal+Engine+UE_4.23\Log.txt for full exception trace)
UATHelper: Packaging (Android (ETC1)): AutomationTool exiting with ExitCode=1 (Error_Unknown)
UATHelper: Packaging (Android (ETC1)): BUILD FAILED
PackagingResults: Error: Can’t make an APK without SDK API ‘android-28’ minimum installed
PackagingResults: Error: Unknown Error

Please, help me.

Well, the last error says

It might be that you do not have APK 28 installed. You will have to download it and install it using android.bat or using AndroidStudio.

Also ensure that your target SDK is 28 and your minimum SDK is anything below SDK 28 that you wish to support.