UE4 and Visual Studio 2015

Hi lz,

You have quite a few interesting questions here. I’m not sure if we have previously addressed any of these, so it may be a good idea to create a new forum post to ask them (in order to keep this thread on the topic of Visual Studio 2015 support in UE4).

Tim

Hello,

I attempted to setup UE4.9 (Release branch) for VS2015 today and got this error:

d:\unreal\UnrealEngine>GenerateProjectFiles.bat -2015
Setting up Unreal Engine 4 project files…

GenerateProjectFiles ERROR: We couldn’t find a valid installation of Visual Studio. This program requires either Visual Studio 2013 or Visual Studio 2012. Ple
ase check that you have Visual Studio installed, then verify that the HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\12.0\InstallDir (or HKEY_LO
CAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\12.0\InstallDir on 32-bit machines) registry value is set. Visual Studio configures this value when it is installed
, and this program expects it to be set to the ‘\Common7\IDE’ sub-folder under a valid Visual Studio installation directory.

Press any key to continue . . .

I only have VS2015 installed. What am I missing?

Thanks,
Jazzay

I checked the files. There is no VS 2015 support. There is a misinformation.

Hi jazzay,

Could you please create a post in the Bug Reports section of the AnswerHub for this issue? We can then make sure it gets assigned to someone to help you out.

Tim

You missed nothing. Had the same issue. Had to make a key in the 12.0 (old install) of vis 2013.

If you dont have an old install, just make a 12.0 folder in the root and add the key with the appropriate path.

Here is a SS of mine that worked:

&stc=1

Is using vs2015 as the ide but targeting the vc120/vs2013 toolset a thing? Or does that just confuse ue?

I just modified the bat files to add support for 2015. I am trying to get my 4.7 project to build, which is a pain.

Just a heads up either Microsoft or the University is pushing to move from 2013 to 2015. This means for a lot of students or indie developers they will not have access to VS2013 through the Github student pack as of a few days ago. I suspect you will get a lot more questions regarding how to run with 2015 in the next little bit.

Just to briefly check, when installing Visual Studio Community 2013 we only need to check “Microsoft Foundation Classes”, right? Everthing else appears to be not necessary for non-Windows-Store, non-Windows-Phone purposes.

I tried this, ended up with Unreal 4.11.0 - but I get this error when I try to start up a code based project.
Should I just give up and install vs2013 for the next month or so?

Running G:/Documents/GitHub/UnrealEngine/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project=“G:/Documents/Unreal Projects/vc2015_t_2/vc2015_t_2.uproject” -game -engine -progress
Discovering modules, targets and source code for game…
UnrealBuildTool Exception: ERROR: Visual C++ must be installed to build this target.

FWIW, after a few attempts, and getting used to Github and VS2013, cloning, compiling etc. of Nvidia VXGI UE4, Oculus Story UE4, things are pretty smooth… The biggest delay is downloading GBs of files. I can’t see why one would want to use VS2015 at this point.

Hello, everyone. I wanted to update everyone that I have compiled a list of additional commits that you will need to cherry-pick in order to be able to build version 4.9.1 from source code using Visual Studio 2015.

First, I would like to apologize for how long it took me to get this information to you. Since this is still in beta and somewhat experimental, I have not been able to dedicate much time to putting this list together. I was able to put aside some time yesterday and today to work on it, and even though the process is not exactly simple, I was able to successfully build the Engine using VS 2015, and run it afterwards.

In order to be able to build 4.9.1 using Visual Studio 2015, you will need to cherry-pick the following commits. It is best to do this in the order that the commits are listed below since some of the commits need to be applied in a specific order.

Using those commits, I was able to build 4.9.1 using Visual Studio 2015. That does not mean the resulting Engine will be fully operational. I did not see any obvious major problems, but I also did not perform any real testing with it. One thing that I did notice is that creating a new code project with this Engine will create a Visual Studio 2013 solution for the project. I am hoping to be able to get some more information tomorrow with regards to how to get your game project to also use VS 2015 (if you try to build the project with VS 2013, it will try to rebuild the Engine with VS 2013 as well since the binaries are different, and the build will likely fail).

Tim

Hi Tim,

recently master branch was switched to use VS 2015 tool chain by default. Though still won’t compile due to issues VS has with win 10 sdk it seems…see my answerhub post: Master branch failed to compile - Programming & Scripting - Unreal Engine Forums

Thanks for your assistance! :slight_smile:

Ruben

No. You don’t need MFC either. Just install blank enough.

Hi Ruben,

Yes, we made the switch internally on Tuesday (though I am still the only person in this department with VS 2015, so I expect I will be getting busy soon). What specific issues are you seeing with VS and Windows 10? The link you provided goes to a post from last year that does not seem to be related to either VS 2015 or Windows 10 (unless I am blind, which is entirely possible).

Tim

Clean VS2015, Windows 7 and master branch commit: cef6a4e1 gives me error when cleaning Solution/Engine/UE4

1>------ Clean started: Project: UE4, Configuration: Development_Editor x64 ------
1> Cleaning UE4Editor Binaries…
1>EXEC : GenerateProjectFiles error : A valid version of Visual Studio does not appear to be installed.
1> Press any key to continue . . .
1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.MakeFile.Targets(32,5): error MSB3073: The command “…\Build\BatchFiles\Clean.bat UE4Editor Win64 Development -waitmutex -2015” exited with code -1.
2>------ Clean started: Project: ShaderCompileWorker, Configuration: Development_Program x64 ------
2> Cleaning ShaderCompileWorker Binaries…
2>EXEC : GenerateProjectFiles error : A valid version of Visual Studio does not appear to be installed.
2> Press any key to continue . . .
2>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.MakeFile.Targets(32,5): error MSB3073: The command “…\Build\BatchFiles\Clean.bat ShaderCompileWorker Win64 Development -waitmutex -2015” exited with code -1.
3>------ Clean started: Project: UnrealBuildTool, Configuration: Development Any CPU ------
4>------ Clean started: Project: DotNETUtilities, Configuration: Development Any CPU ------
5>------ Clean started: Project: EnvVarsToXML, Configuration: Development Any CPU ------
========== Clean: 3 succeeded, 2 failed, 0 skipped ==========

After picking those commits to a 4.9.1 branch with



git cherry-pick  --strategy=recursive -X theirs 60c927d27a0fcac3d2e2e2127d919b1feed8dc62
git cherry-pick  --strategy=recursive -X theirs 8c38dfc5089cce8715feefd0fb85811afbdee0d2
git cherry-pick  --strategy=recursive -X theirs cdb5545e3b7bff06ff8c63e5572b397bbb81787b
git cherry-pick  --strategy=recursive -X theirs a0006fe168ef1711e8a1ec663b45ad1392a8197b
git cherry-pick  --strategy=recursive -X theirs f9b44cc1e512447b5369690648e5e0c23ab5b4c6
git cherry-pick  --strategy=recursive -X theirs 3e760093cd82b59bacf6750c1a2f9635b7e8cba5
git cherry-pick  --strategy=recursive -X theirs 7e33541631a4531f7e7240dafdf1200a77fac63e
git cherry-pick  --strategy=recursive -X theirs a92c3dd952d24d37992d24f5747ce07463d0cfd6
git cherry-pick  --strategy=recursive -X theirs 04c87fdc770c6edabf67f57105f9e4b6ba177cf6
git cherry-pick  --strategy=recursive -X theirs 3ed1031101bb30b1ef0e25b4f6af8f829dcb9f8a
git cherry-pick  --strategy=recursive -X theirs 24f87f4cadd43d4a963196a7efb35c75868a4a4f
git cherry-pick  --strategy=recursive -X theirs 631703e3a48c0a042afe3a54291d5f5ad36e334f
git cherry-pick  --strategy=recursive -X theirs f0bb0021b8ede74eb35222f0785903ee1c8a1ba5
git cherry-pick  --strategy=recursive -X theirs b53e3fb6c8922cf4d1daaa99f8ee17868d4ac2a2
git cherry-pick  --strategy=recursive -X theirs 5eac09ae0ae47ea95134666dbf4236df5fee2989
git cherry-pick  --strategy=recursive -X theirs cadd7544f9658091c0103f5fa07f5eb58f739a95
git cherry-pick  --strategy=recursive -X theirs acb186e6d32b3b74f7f50fced1b1b497d3a68b20
git cherry-pick  --strategy=recursive -X theirs 965a82a1e54a6d883b79e1b8bdb6d615795dbd80
git cherry-pick  --strategy=recursive -X theirs 35d4842420f07301ed048075104d5555cd1000b6
git cherry-pick  --strategy=recursive -X theirs 6e5b895a5471c75f6c38c8086a50aecc0c65cec1
git cherry-pick  --strategy=recursive -X theirs d8e7e194ff0998a5b8f3798092d1705b9e32ddf8
git cherry-pick  --strategy=recursive -X theirs 22f2f3421feb9a1dae96f33841113569078acec5
git cherry-pick  --strategy=recursive -X theirs 85487f2f604e6bfec20ed2ec9f5fa925726426c0
git cherry-pick  --strategy=recursive -X theirs e72d53724e5b272a41966154dfa0c54ffb07c6ef
git cherry-pick  --strategy=recursive -X theirs f30e3d0c0ed839c42f934ba683fdd40b5c4b5f56
git cherry-pick  --strategy=recursive -X theirs e757dc2c9fa3c3fed23bdcdfc7c0a5612ccb8eae
git cherry-pick  --strategy=recursive -X theirs 47a5d75a06acd1dbe2375bb7ef612c1da8cea559


Building fails with all “PCLaunch.rc(125) : fatal error RC1015: cannot open include file ‘PCLaunch.rc2’.”

Wrong cherry-picking strategy? Or did the latest Windows 10 SDK update mess up include paths?

It says though in the Readme “Be sure to include the MFC libraries as part of the install (it’s included by default), which we need for ATL support.”?

Can someone confirm this? Cheers.

Hello, I am not able to open one of my projects because it says I don’t have visual studio installed. I am using VS2015 and my environmental var is VS140COMNTOOLS. Any ideas how to get this to work?

I get the following warning when building 4.9.2.

C:\Program Files (x86)\MSBuild\14.0\bin\Microsoft.CSharp.CurrentVersion.targets(133,9): warning MSB3884: Could not find rule set file “MinimumRecommendedRules.ruleset”. [C:\Program Files\Epic Games\4.9_2015\Engine\Source\Programs\UnrealBuildTool\UnrealBuildTool.csproj]

Should I be concerned?

edit

The above warning occurs when executing “GenerateProjectFiles.bat -2015”.

I get the same warning followed by dozens of errors when trying to Build the project from within VS 2015.

I eventually gave up and installed VS 2013.