UE4 All was fine, suddenly project crashing on save/compile, please help!


I’ve been following along some video tutorials on a 4.8 project. When I closed it and re-opened, it was on a crash loop trying to open. I then found I could open it, but pressing play/save/compile on anything it crashed and gave me this log below. I’ve tried copying to a 4.10 but get the same problem.

Don’t know if it helps but I was at this point in the video tut, just after adding some join game/host game functions to a game lobby widget and main menu being built - Unreal Engine 4 RTS Series Part 5 Multiplayer Lobby - YouTube

Please help. Big thanks if you have any suggestions as lots of work rides on it.



Access violation - code c0000005 (first/second chance not available)

"Fatal error: [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.8\Engine\Source\Runtime\Core\Private\Windows\WindowsRunnableThread.cpp] [Line: 42]
Runnable thread TaskGraphThread 0

UE4Editor_CoreUObject!UObjectBase::IsValidLowLevelFast() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\coreuobject\private\uobject\uobjectbase.cpp:237]
UE4Editor_CoreUObject!FGCCollector::HandleObjectReference() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\coreuobject\private\uobject\garbagecollection.cpp:388]
UE4Editor_Engine!FSimpleObjectReferenceCollectorArchive::operator<<() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\coreuobject\public\uobject\garbagecollection.h:461]
UE4Editor_CoreUObject!UObjectProperty::SerializeItem() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\coreuobject\private\uobject\propertyobject.cpp:32]
UE4Editor_CoreUObject!UStruct::SerializeBin() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\coreuobject\private\uobject\class.cpp:760]
UE4Editor_Engine!UBlueprintGeneratedClass::AddReferencedObjectsInUbergraphFrame() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\engine\private\blueprintgeneratedclass.cpp:680]
UE4Editor_CoreUObject!FArchiveRealtimeGC::ProcessObjectArray() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\coreuobject\private\uobject\garbagecollection.cpp:832]
UE4Editor_CoreUObject!TGraphTask::ExecuteTask() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\core\public\async\taskgraphinterfaces.h:771]
UE4Editor_Core!FTaskThread::ProcessTasks() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\core\private\async\taskgraph.cpp:430]
UE4Editor_Core!FTaskThread::ProcessTasksUntilQuit() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\core\private\async\taskgraph.cpp:273]
UE4Editor_Core!FTaskThread::Run() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\core\private\async\taskgraph.cpp:564]
UE4Editor_Core!FRunnableThreadWin::Run() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:73]

Hi TotesAmaze,

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?
  • What steps can I take to reproduce this on my end?
  • Can you post the crash logs here so I can take a look? They can be found at \Unreal Projects\PROJECTNAME\saved\logs\
  • Have you tried updating from 4.8 to 4.9 and then to 4.10 instead of doing the immediate jump to 4.10?
  • Is this a blueprint or a c++ project?

Hi ,

Thanks for the fast reply! To your points:

  • No, and an old version of this project opens and compiles fine, and other projects I have work.
  • I will upload the project tomorrow on dropbox and send a link.
  • I’ve put afew of the many crash logs here - two small ones and one big. I think the long RTSGold_3 one is from the time of the first crash, other from repeat ones later. Let me know if you need more: Dropbox - CrashLogs - Simplify your life
  • Not yet, Ill try copying to 4.9
  • Its a blueprint only project copying and learning from pally qle’s videos.

Thanks again, Ill update when i get a chance to upload the project.

Here’s the dropbox link to the project, thanks if you have time to peek at it: Dropbox - RTSGoldCrashOld.zip - Simplify your life

Try clearing your content folder to see if this is specific to assets. To do this, go to your windows explorer>Unreal Projects\PROJECTNAME\content and move all of the folders to a new location (empty folder on desktop is sufficient). Once you’ve done this, open the project and try pressing PIE or create a new blueprint and press compile. Does this error occur again? I was able to get the crash to occur even back in 4.8, so I believe this may not be a conversion error but a content based crash.

It must be a specific error on one of my blueprints. I did what you said and removed the content folder, made a new blueprint and it compiled fine and PIE worked. Now I’m not sure where to start looking with my blueprints at what could be causing the problem. Were the log files helpful at all?

I saw lines complaining about some blueprints but no idea which one might be crashing it. What I might try now is taking out chunks of content at a time and try to work out where the problem is…

I think Ive narrowed it down to something in the Content>A_RTS>Blueprints>A_Units or Logic folder crashing it, as things seem to compile and play without crashing when those folders are absent.

Latest log file “RTSGold” is here - can anyone discern anything from it? Dropbox - LatestProject - Simplify your life

The error I am seeing is pointing to a null pointer. Have you run a “fix up redirectors” on your contents folder? If not, go to the content folder in the editor>RMB>Fix Up Redirectors. This will clean up pointers and rereference assets to ensure the are all properly pointing to the correct assets. It is important to do this if you ever rename or move an asset.

Hi TotesAmaze,

We have not heard from you in several days. I am marking this as answered for tracking purposes. If you are still experiencing this error, please comment and I’ll take another look.