UE4.9.1 on OSX 10.10.5 requires new install for each non-admin user

I’ve installed UE4.9.1 on OSX 10.10.5 as an administrator and it works as expected when started as administrator.

However, if I start a Game Launcher as a regular, non-admin user it requires a new engine installation for this particular user.

It does not matter if I go offline or sign in with my Epic account - new engine installation is required.

I see an error in EpicGamesLauncher.log complaining about “Module ‘PakFile” not found. Not sure if it’s related.

I’ve tried this solution for engine manifests to no avail UE4 install and engine update on OS X - Getting Started & Setup - Epic Developer Community Forums

I’d appreciate any thoughts and ideas.


Hi aroudik,

Is there a reason you have to have the engine installed as an administrator? If not, save your projects to a safe place and reinstall the engine normally, not as an administrator. Then return your projects to the proper directory.

Let me know if this will work for you or if you must have it installed as administrator.


Hi ,

Thanks for your response. This is a lab installation. I need all users to be able to work with this installation without installing UE for each user.


Did you follow the instructions for the Unreal Engine 4 - Academic Installation?

Yes, it is Windows based and way outdated. The results are as described above.

I see you tried the solution of copying the engine manifests from the admin account to the user accounts. There seemed like there could be some confusion from which “Library” directory to copy these from. To be clear, this is the Library directory that can only be displayed under the “go” tab by pressing the Command + Option keys.

If that is indeed where you copied the files from and you are continuing to experience this problem, please provide us with the logs from a launcher running on one of the deployed macs or any other than the administrator account. Instructions on how to do that can be found here: Troubleshooting Launcher Problems

There is no confusion about the Library location as the manifest file can be found at the user’s directory only /Users/admin/Library/Application\ Support/Epic/EpicGamesLauncher/Data/Manifests/*.manifest.

Copying the manifest file to the other user’s directory to make UE work is not a solution.

If Epic Games, Inc is interested in its products to be used for teaching in academia there should be a clean solution to the lab installations when all users could use the UE without tweaks and workarounds.

Please, do not mark this thread as solved until it is solved.

Hi aroudik,

The issue appears to be related to how manifests are being stored in the user directory on Mac academic installations and has been reported as JIRA [OPP-4410]. Since our developers have now been made aware of the issue and will be working on the issue accordingly, we will be marking the post as “answered” for tracking purposes as there is no further support we can offer at this time. However, once the issue has been addressed and updated in our bug report system, we will notify you with an update to this thread.

Thank you for reporting this issue.