Download

UE4.9.1 does not recognise Rift with 0.6.0.1, and has game breaking performance with 0.7.0.0

I thought hmd sp was deprecated and we were supposed to use hmd pd…so confusing! hmd sp at 90 got my stutter a little more under control but the quality is pretty bad now. hmd pd never really did anything no matter how low I set it. (i’m in 4.9.1 with .7, 355.98 nvidia drivers)

I wish there was a way for independent, amateur developers to get reliable info on this stuff. Like a comprehensive list of console commands and information about them like defaults, what they do…etc…like, where did this poster get this list from? https://forums.oculus.com/viewtopic.php?t=25215#p287626
and how reliable is it?

Is it possible to uninstall engine updates from the launcher? I just completely removed 4.9.1 thinking I could add 4.9.0, but it doesn’t show up.

I was going to run some comparison benchmarks of the two engine versions and the two runtime versions to hopefully get an idea of where the issues show up most, and exactly how much worse the performance is, but engine installs seem to be locked to their latest stable update.

And is it possible to force 4.9.1 to recognize 0.6.01 at all? If features and support for certain software are going to be removed from the Engine (especially in ‘hotfix’ updates which imply that only small fixes will be included) it would be really great if it was mentioned in the announcement threads.

Hey Guys,

I was messing around with my DK2 last night and I would like for anyone who is having performance issues to try the following.
Create a new project and instead of using the maximum quality settings try and use the mobile / table setting and see if you get the same problems persist. If it does then add a Post Process volume to the world, set it to be unbound, and then inside of the Lens flares, Reflections, AO, and Bloom sections enable the first property but set it’s value to 0. Then try out the headset and see if your performance problems still happen. If you notice that a certain feature cause the HMD causes lag when enabled please let us know so we can look into it.

Cheers-

Sam

Hey Sam,

I appreciate the suggestion, but how would this contribute to debugging?

I may have misunderstood your post, but the issue is a performance drop compared to a previous engine version with all the same project settings. Obviously creating a blank project with the quality of post processing, reflections, ambient occlusion, bloom at 0 would make performance good in VR, but what would it prove?

I can also achieve performance gains similar to my 4.8.3 and 4.9.0 projects in 4.9.1 by turning off reflections, and turning down screen percentage, but that’s obviously not a solution to anything.

This would contribute to debugging in a major way because without first knowing what works you can not determine what is broken. Getting a project to a state where it is running at the proper frame rate and then re-enabling options one by one to see which options or combination of options causes the issues gives us a better idea of what is happening in between builds. If for **EXAMPLE **(This is **PURELY **for example sake as I have no data that would otherwise back this up) you find that enabling bloom causes FPS issues on 4.9 but did not in 4.8, we can then look at that code, see what changed were made and why that is affecting VR. Just simply saying that the performance in 4.9 is worse than the performance in 4.8 gives me nothing to go on, I need more data than that to make a case about performance.

You’re right, I understand now. I’ll begin debugging with your suggestions.

Sorry i can’t help much in this case because i haven’t seen any performance issue with 0.7.0.0 + 4.9.1 on my machine.

However would it not be a better approach to simply record a couple of profiles (.ue4stats) in the same problematic map and in the exact same location but running on different versions of the runtime/engine, and then compare them?

Yes that is a totally valid way to do test performance but I find it easier (and this is just me) to first compare if different Rendering settings are causing the issues and if that does not cause the problem I look at performance profiles to see if I can figure out what is going on. Performance profiles can be a bit overwhelming at first especially if you do not know what you should be looking for.

I’m back with some numbers; I barely know what I’m looking at, but what I’m hoping is that it sparks enough of a concern to have it looked into by Oculus and Epic. I used Vehicle Game (completely unmodified) to test because it’s something that has a fair balance of CPU and GPU going on, and anyone else can download it to replicate these results.

I created a project in 4.8.3 and 4.9.1, and took screenshots with stat unit, and stat fps displayed. I apologize that I don’t know how to more efficiently benchmark than this. I couldn’t get the more advanced render stats to draw on the VR screen, such as the draw calls and render query result stuff. I took two samples from different points in the track to rule out anomalies (I started with 3 on the first couple of tests as you can see, but I realized that it would be a nightmare to type out, hopefully two is enough)

I used 4 tiers of quality settings in each Engine + Runtime combination just to be thorough, and in hopes that people smarter than me might find some pattern:

  1. ‘Epic’ settings in Engine Scalability menu with all post process settings at default
  2. ‘Low’ settings in Engine Scalability menu with all post process settings at default
  3. ‘Epic’ settings with AA, AO, Bloom, Lens Flare, and SSR OFF
  4. ‘Low’ settings AA, AO, Bloom, Lens Flare, and SSR OFF

All of the benchmarks used 100% HMD screen percentage

4.9.1 with 0.7


•Epic		
	FPS	47.50		47.72		47.60
	Frame	20.00ms		20.35ms		20.36ms
	Game	4.40ms		4.12ms		4.00ms
	Draw	9.12ms		8.22ms		5.18ms
	GPU	20.27ms		19.98ms		19.81ms

•Low		
	FPS	47.70		47.72		50.36
	Frame	20.35ms		20.35ms		19.63ms
	Game	4.37ms		4.09ms		4.06ms
	Draw	10.40ms		8.37ms		4.97ms
	GPU	20.01ms		19.88ms		18.90ms

•Epic with AA, AO, Bloom, Lens Flare OFF
		
	FPS	52.54		74.99		
	Frame	19.64ms		13.33ms		
	Game	4.41ms		3.73ms		
	Draw	8.37ms		5.13ms		
	GPU	20.25ms		13.36ms		

•Low with AA, AO, Bloom, Lens Flare OFF
		
	FPS	74.99		75.02		
	Frame	13.34ms		13.33ms		
	Game	3.93ms		3.66ms		
	Draw	7.84ms		4.34ms		
	GPU	13.38ms		13.36ms	

4.8.3 with 0.7


•Epic

	FPS	57.34		62.25		
	Frame	16.40ms		10.47ms		
	Game	4.22ms		4.16ms		
	Draw	5.06ms		8.34ms		
	GPU	15.80ms		16.76ms	

•Low

	FPS	58.83		64.23		
	Frame	16.83ms		15.53ms		
	Game	4.33ms		4.36ms		
	Draw	9.67ms		5.20ms		
	GPU	16.58ms		15.56ms	

•Epic with AA, AO, Bloom, Lens Flare OFF
		
	FPS	74.98		75.06		
	Frame	13.33ms		13.33ms		
	Game	3.95ms		3.65ms		
	Draw	8.37ms		4.04ms		
	GPU	13.33ms		13.32ms	

•Low with AA, AO, Bloom, Lens Flare OFF
		
	FPS	75.12		75.01		
	Frame	13.33ms		13.33ms		
	Game	3.93ms		3.91ms		
	Draw	4.28ms		7.93ms		
	GPU	13.35ms		13.31ms	

4.8.3 with 0.6.0.1


•Epic		
	FPS	75.12		74.97		
	Frame	13.33ms		13.33ms		
	Game	4.06ms		3.65ms		
	Draw	8.66ms		4.40ms		
	GPU	13.32ms		13.33ms		

•Low		
	FPS	74.96		74.08		
	Frame	13.34ms		13.77ms		
	Game	4.00ms		4.77ms		
	Draw	9.69ms		5.23ms		
	GPU	13.35ms		13.81ms	

•Epic with AA, AO, Bloom, Lens Flare OFF
		
	FPS	75.00		74.97		
	Frame	13.33ms		13.34ms		
	Game	3.95ms		3.90ms		
	Draw	7.87ms		5.01ms		
	GPU	13.33ms		13.32ms		

•Low with AA, AO, Bloom, Lens Flare OFF
		
	FPS	75.05		74.98		
	Frame	13.33ms		13.33ms		
	Game	4.04ms		3.91ms		
	Draw	7.93ms		4.73ms		
	GPU	13.33ms		13.35ms	

In conclusion of these three benchmarks, at 100% HMD SP, the lowest possible settings I could achieve with both 4.8.3 and 4.9.1 with runtime 0.7 barely keeps up with the highest possible settings with 4.8.3 and runtime 0.6.0.1: heavily implying that the issue is with Oculus’ runtime. These benchmarks don’t reflect frame time variance, which 0.6.0.1 also performed better at even when the performance was comparable between the two runtimes.

Out of curiosity, I also benched 4.8.3 and 0.6.0.1 with an increased HMD SP, trying to achieve similar performance to the bad 0.7 results. The result was that @ 130% HMD SP, 4.8.3 + 0.6.0.1 was roughly as performant as 0.7 @ 100% HMD SP.


•Epic		
	FPS	58.98		69.99		
	Frame	16.72ms		15.02ms		
	Game	4.28ms		4.07ms		
	Draw	7.84ms		5.76ms		
	GPU	16.44ms		15.56ms		

•Low		
	FPS	58.84		59.82		
	Frame	16.82ms		14.99ms		
	Game	4.29ms		4.14ms		
	Draw	9.63ms		4.87ms		
	GPU	16.53ms		13.94ms	

•Epic with AA, AO, Bloom, Lens Flare OFF
		
	FPS	74.98		69.55		
	Frame	13.34ms		14.23ms		
	Game	4.10ms		4.22ms		
	Draw	4.79ms		7.82ms		
	GPU	13.51ms		13.92ms		

•Low with AA, AO, Bloom, Lens Flare OFF
		
	FPS	75.03		75.16		
	Frame	13.34ms		13.33ms		
	Game	4.15ms		4.05ms		
	Draw	3.17ms		4.75ms		
	GPU	13.35ms		13.33ms	

I have saved all the screenshots with stats, if Epic wants I can annotate them and upload somewhere, but the numbers written above are those results converted into a text format. I’d really appreciate it if this was replicated at Epic so that the information can be forwarded in an official manner to Oculus or whatever it takes to fix this. My hardware is as follows, but looking at the other responses in this thread, I’m positive it is not just my specific set up that’s affected:

4GBGTX 680 (stock)
3930k@3.20Ghz (stock)
32GB RAM

Hey Mechanicalsnowman,

Thanks for the detailed feedback and I will make sure to pass it along to the VR guys. If I hear anything back about this I will be sure to let you know.

Just wanted to confirm that I’ve got the same issue. Went from a solid 75fps in 4.8 to horrible judder and 47 - 57fps in 4.9, which means it’s unusable, so I’m going back to 4.8. Hope a fix can be found.

I currently still need 0.6.0.1 due to it’s backwards compatibility with some older 0.4.4 projects.
Since I was already on 4.9.1, I ended up getting the 4.9.0 tag code from GitHub (uses the 0.6.0.1 runtime) and compiled the engine from source. No problems compiling from source and works now with Showdown project (GTX 980 Ti with 355.84, 75fps with HMD SP 200). So fear not the compilation from source.

Is that the 4.9.0-release one, or one of the previews?

tags/4.9.0-release (311e18f)

Appreciated! I didn’t see mention of which version of OR was being used where, so many thanks.

We’ve also seen the large VR performance drop with 4.9.1. Our framerates when using the Rift went from a solid 75fps to frequently under 50fps with no other changes other than updating to 4.9.1.

Please try the following and let me know if this helps or not. While your game is running open up the console and input the following command.

HMD SP 130

After pressing enter see if your FPS goes back up to the 75 FPS you were seeing before.

Adding to the people who are experiencing serious slowdown on the UE4.9.1 + Oc0.7.0 combo.
It would be great if this could get looked at please?

Cheers
Fred

Hey everybody,

I did some testing and figured out that it is most likely the AO Post Process that is causing the lag you are experiencing. Turn off AO by setting the intensity to 0 and see if your lag stops. I have tried this with a Vive and DK2 and both times disabling this made my frame rate go back up to normal.

Would that also explain why my frame rate went up back to normal when I brought down the Engine Scalability setting for Post Processing?