UE4.8.2 crashing while inserting more than 1 file(PNG) when source control svn ON

while inserting more than 1 file UE crashes.

tried with 2, 5, 15 and a whole directory with subdirectories(about 50 files).

same error every time.

this only happens when source control is ON.

dumpfiles are saved and send, if you need.

is this a known issue/bug?

Many thanks.



tried following:

  • switched svn to OFF
  • inserted the directory
  • subdirectory and PNGs
  • switched svn ON
  • tried commit


same behaviour when renaming a file.

Hi MagicTigger -

I have entered a bug report as UE-18885 for your crash. As we investigate this issue further I will keep you informed here.

Thank You

Eric Ketchum

Heya Eric!

if you need more information, feel free to contact me.

short addendum: when switching svn OFF and inserting and then switching svn ON it works(commits).

and another thing i noticed. when this error occurs the used RAM is more than doubled. (maybe a garbage collector issue?) i.e. UE4Editor.exe uses 981MB, when this error occurs it jumps up to 2,4GB.

Hi MagicTigger

I’m not able to reproduce this on my current build; do you have any console log output which might be of help in order to see what’s going on here (run the executable with -log)? Also, to clarify, does this happen when importing png files via the Content Browser?

The second error you mention - has the asset been added to SVN at that point? I’m guessing not. There seems to be some issue with syncing the new assets or adding them while importing them. Which context menu options are available to you on the newly imported files after reenabling source control?

Heya Richard,

thanks for analysis.

Meanwhile I updated to 4.8.3
with following changes:

  • I can insert up to 4 objects while SVN is set to ON.

Setting logging brought following:
After 4 objects(PNGs) it took 2 minutes(before it took only seconds) to do “LogD3D11RHI”
and after that it does (nearly) nothing, besides these (2) errors:
Timed out while waiting for GPU to catch up. (0.5 s)

CPU is idling.

I stopped/killed UE editor now after 45 minutes doing “nothing”.

Please find logfile (for 2 weeks) at http://pastebin.com/DHvUsPtq

Hope you now can see or have an idea.

Many thanks.



Are all the multiple occurrences of ‘InitD3DDevice’ in the logs something that you’ve added yourself?

Just to be clear, exactly which operations did you perform during that session? It looks like you committed some assets to SVN and have then imported some new .pngs. Are you importing via the Content Browser menu, or by copying some .png assets somewhere into the Content directory of your project?

Given the GPU hang, I’m inclined to think this isn’t entirely to do with source control at all, but unfortunately I don’t have enough info to go on yet…

Do you have a vanilla build of the engine (4.8.3) that you can try this out on, i.e. one with no custom modifications, using a blank new project? I’d like to be able to rule out (or not) whether it’s due to any project code, or whether it’s maybe a hardware issue. Also, which version of SVN are you on? Do you have your own installation or are you using the one supplied with the engine?


Dear ,

  1. correct, all of the InitD3DDevice are new PNGs (same pixel 512by512)
    1. I switched SVN to on
    1. inserted 2 PNGs (2x)
    1. inserted 4 PNGs
    1. tried to insert 8 PNGs

do you need the build of a new project? I will start and build and give a link to it.
give me a day to do so.

Many thanks.



Dear ,

find the vanilla build at Dropbox - Error



P.S.: I will delete this after you say that you got the file. :slight_smile:

Sorry, what I was asking is if you could try this yourself on an unmodified build of the engine on your machine - I’d like to be certain whether this is an issue caused by your hardware/software configuration or not. The GPU hangs point towards some other problem.

I’m not able to reproduce this locally so I need to get some idea of what external factor might be causing the issue.


Aw… Sorry… And sorry for late reply…
Did it now in vanilla and have the same result…
Created empty repository, checked out… Turned SVN on… tried to insert more than 4 PNGs… And waiting and waiting… :frowning: No crash since 4.8.3 but nothing happens (standing still at 27% / 15 PNGs to upload )

Can you paste in the log output please from your recent attempt (where it hung at 27%). To be honest, I’m not sure how to go about analysing this, given I can’t reproduce it myself. I’m hoping there might be the smallest little clue in the logs…

Also could you clarify what you mean by ‘inserting’ PNGs? Are you importing them explicitly (using the Import button) into the Content folder or a sub-folder? Or is it importing them automatically (by discovering new PNGs in the Content folder which you copy across)? How big are the PNGs? What happens if you create a folder of 16 PNGs (512x512 let’s say) somewhere else and attempt to import that in one batch?

Sorry for all the questions, I’m trying to get a handle on the problem and I need all the details I can get

Thanks for your patience!

Heya Richard,
please find attached the log: http://pastebin.com/vRnkfLxb
I’ve switched to 4.9.0 and there it doesn’t happen.
So if I’m the only one with this issue you can close this, as I’m opening a new thread if this will happen in 4.9.x again.
Many thanks.



Happy to hear you’re not having problems with 4.9. I’m going to close the thread, but if you experience any other problems, please let us know!

All the best,