UE4.5 demos broken on OSX Yosemite

I updated my iMac from OSX 10.9.5 to 10.10 (final) and most of the the UE4.5 demos are broken and unusable. They worked flawlessly on OSX 10.9.5.

Take a look at Matinee on OSX 10.10:

The characters are all messed up and some shaders are not correctly represented.

Here is the ContentExamples Animation sample scene:

Seems like animated characters are the most affected.

Is this a known problem?

Thanks.

Hello, I also have animation problems, I am on osx yosemite and use unreal engine 4.5, i have a mac book pro retina 2012 edition.
This is in the FPS demo, in the first screenshot the object in the middle of the screen is a rigged cube imported from blender

18329-18330-

There’s a bug in NVIDIA driver in Yosemite that causes this. Apple and NVIDIA are working on this, but in a meantime we prepared a workaround, which you can download from here: https://s3.amazonaws.com/unrealengine/qfe/QFE-FromCL-2326468-Shelve-2331902_Mac.zip (92 MB) Just unpack the zip file and run the patch installer. It will also be included in UE 4.5.1.

Thank you very much

I’m sorry to say that the QFE doesn’t solve the problem for me. I run QFE-FromCL-2326468-Shelve-2331902.app from the Desktop and I get no error, no installation visual feedback… nothing. I run Matinee and the problem is still there.

same for me unfortunately, however it is specifically after i import a rigged cube, tested that on the demo with paper 2d

Hmm. No idea how did this happen, but the patch is missing a file. Sorry about that!

I will prepare a fixed zip, but in a meantime, if you don’t want to wait:

Please unzip the attached Base.lproj.zip, then right click on QFE-FromCL-2326468-Shelve-2331902.app, select Show Package Contents and move the unzipped Base.lproj folder to Contents/Resources in there.

link text

ew well sorry but now the engine wont launch ^^’, it puts a few seconds launching then just stops, like it autocloses. I reinstalled 4.5 and now it launches, but there is still the animation freezing problem it comes only when I import a skeletal mesh.

I’m terribly sorry about that. Apparently I made a mistake when preparing a patch and built it for different build of the engine that was actually released. I’ll prepare a new, correct one immediately.

As it turns out, 4.5.1 should be released tomorrow and will include this fix, so please just wait for that. Again, apologies for the broken patch and many thanks for patience.

No problem thanks for the help^^

Thanks Michael, I’ll wait for 4.5.1

This should be fixed by the full 4.5.1 update which includes the required workaround for an Apple/Nvidia OpenGL driver bug introduced in 10.10.0.