Download

UE4 4.9 Leap motion support

Hello everyone,
First post, new to Unreal engine and the forum. I am new to real-time, but have extensive knowledge of precalculated 3d.

Right now, I am building a simple scene where I want my leap motion hands to follow the character. However, whenever I tick “attach to character” in the leap motion hand properties (or something along those lines I don’t have Unreal open right here, will need to check tonight), the hands are:

  • only visible if I scale them a bit
  • moving away from the character as I move it.

It looks like they have a double transform rather than just link to the parent. (I.e: when I move the character by 1m, they move by 2m )

I have not yet tried to re-install 4.7 and install the leap motion plugin separately, but I could not make it work in 4.9

Has anyone experienced a similar issue?

Thanks,

Mat

I would try it in the latest version of 4.8 rather than the 4.9 preview

Hello,
Thanks for the reply Darthviper, I tried with 4.8 and the hand to player attachement worked, but the hand tracking was fuzzy (known issue on 4.8). I have downloaded 4.7 overnight, and will try with 4.7 + the getnamo plugin.

UE3’s SDK is referred to as UDK and as far as I’m aware UE4 is just referred to as UE4 not UDK. Fyi

Oops, my bad. Can’t change the thread title unfortunately.

I’m getting the same issue in the latest (non-preview) version of 4.9. In 4.8 the Leap Motion controller worked by adding it as a component to my player’s mesh, although it was jittery, the hands at least stayed with the player, and with some code it would follow the HMD quite well.

But now in 4.9 the LM consistently does the same double transform thing as you said, so that as I move away from a certain point, the hands move twice as far in that direction. The hands do follow the cameras rotation, but on my maps they are like tiny blips off in the distance.

Ive tried attaching the hands using different methods to my mesh and to different object, and tried moving the LM controller to different spots in a tick function, and I’ve also tried adding the LM to different actors and made it into its own actor and put it on the level. Also I’ve tried the auto attach Camera option on and off and that doesn’t help either. I suspect there’s a way to attach it correctly, but I haven’t figured it out.

Any help from anyone would be really appreciated.

I’ve got the same problem. If you pause the game and check the location of the controller, it will be correct (Attached to the player). I think it’s the transform of the bones relative to the controller that is the problem.

I didn’t get any further than that in trying to solve the problem though.

I have had similar issues. The offset it relative to the world origin. It makes it impossible to attach the Leap Motion controller to a character, or even change the orientation. Pretty much useless in this state.

Going to cross-post from this thread, as the issue is the same.

Sorry about this issue, folks – we experienced the same issues with the LeapCharacterExample, which is why we had to pull it from the 4.9 demo pack. We’re pushing to have a really solid update land before the 3D Jam on September 28th. In the longer term, we’ve actually been looking for a full-time engineer who can help us bring the Unreal plugin to the caliber that you expect and deserve.

Stay tuned and thanks for your patience. You can email me directly at acolgan@leapmotion.com if you have any questions.