UE4 4.27 editor freeze when changing scalability setting

As the title says the 4.27.2 editor freeze when hovering the scalability settings button. It is exactly the same issue like this: UE4 4.27 out of memory crash on opening scalability window - YouTube, but the editor doesn’t crash because out of ram.
I watched the process in the task manager when I try to change that, the editor got suspended then did not respond.
I can’t rid of that issue for months.

I tested on another computer as well, but everything is fine on that. I even reinstalled the Win 10, Epic Games Launcher, and the engine too.

Any ideas how to fix it?

I found this problem was due to a massive shader compile getting ready. Literally locked up for about 5 mins, and then spent 45 mins compiling shaders.

Could it be that?

Thank you for the reply.

I let it compile for hours but don’t get it done, so I think something different going on here.

I forget to mention that when I also open a brand new project the scalability setting is always low at default.

The scalability is an engine setting, so the new project being low makes sense.

In the 4.26 project, the default scalability setting is:

And in the 4.27 project, the default scalability setting is low:

Then when I just try to open that setting it just freezes the editor.

Hmm, hard to know. Did you try verifying the engine?


( long shot ).

Yes, I did everything is possible to get it working, even tried to copy this engine from a computer that has no issue with that, but no luck.

What is the spec of the problem machine?


Hmm, looks ok - I’m out of ideas for the minute… :-/

I had this issue just a few minutes ago. Choosing “Scalability Low” was giving freeze.

So I did simple Blueprint in actual level on BeginPlay → Set Scalability Quality to Epic and voila. It worked. I hope it will work for you too.

Mine issue appeared after Blueprint node “Run Hardware Benchmark”. Took me two * hours to figure out what’s going on. I was one step to use Perforce and step back with some stuff :slight_smile:

1 Like

This doesn’t seem to be a permanent solution however ,restarting the editor causes the issue to return until you run the fix again, which isn’t quite a full solution.

I bought a brand new PC yesterday and doesn’t have this problem anymore.

Because of reinstalling UE4 probably :slight_smile:

it means you redoing somewhere the bad step in nodes/code.

It happens even on an blank project, as well as on my work project, and personal projects all in 4.27 Wasn’t a problem on 4.26 and before.

the question is when. I mean you create new empty project and you have low scalability on screen and freezing UE4?

So if I create a new project, it defaults to medium scalability (yellow button on toolbar next to show in the viewport. If I click on that, or in the settings dropdown mouse over the scalability fold-out the editor will hang and the memory will climb til full.

I’ve tried verifying files, and reinstalling but neither worked.

I tried a blueprint solution given above where on begin play set scalability to epic. This fixes it for that session, but on the next launch the editor has defaulted back to medium.

I am going to have a look through .inis for where it’s set and see if I can change it there.

check what you have in Engine/Config/BaseScalability.ini, donot change it, just check, then what has been written to project DefaultEngine.ini and if you have DefaultScalability.ini

Also check if you have something that does “apply settings” for game user settings as it actually do save of this settings after applying.