UE4 4.25 Linux -- Ubuntu 20.04 ok. Fedora or Centos 8 complains about Vulkan

Hi,

My department (at a university) supports CENTOS 8 for Linux. While I’m exploring to see if Windows may be an option, I was trying to make 4.25 run on Linux.

Ubuntu worked fine.

Fedora and Centos 8 did not. It complains about the Vulkan Drivers. I tried many things… Before exploring into another machine and more troubleshooting, I wanted to know if anyone here has successfully run 4.25 on a Linux distro other than UBUNTU? I know UE says they only support Ubuntu (latest version), which makes total sense.

I think I’m trying to make sure that it doesn’t work (without tons of work) on Fedora or Centos (specially CentOS) to make the argument for Ubuntu and/or Windows.

The error says that it requires Vulkan… Online there are options to run it with -opengl4 but 4.25 doesn’t seem to support it anymore. Any comments, tips, help, will be greatly appreciated.

Thanks,

Since there was no reply to this question previously, I presume there was an unresolvable problem wrt Fedora . . I am a potential newbie and have asked another question before I even get started - but if there is positive feedback from that question, I would still need to be able to get UE running on Fedora . .

Are you having any specific issues with getting UE to run on fedora?

Have you tried the compilation and run of UE from the git repo on your fedora setup? If so could you provide some of the following information:

  • What steps have you taken?
  • What are the errors you are getting?
  • What are the hardware and software specs of your setup?

Hi,
I’ve been able to build and run UE 4.27.2 on Fedora 35 without problems following the tutorial at the page:

(I’ve downloaded the zip file from GitHub)

1 Like